WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Jetpack Gallery (6 posts)

  1. Nightcap
    Member
    Posted 7 months ago #

    This evening I installed Jetpack v2.4 and I immediately encountered a problem with the Jetpack Gallery.

    When I add pictures to my post(s) and I select to display them as a "Thumbnail Grid" the pictures are shown as "Tiled Mosaic" in the posts. No matter what I try, the choice "Thumbnail Grid" always goes back to "Tiled Mosaic" in the dropbox. Is this a bug in the latest JetPack version?

    http://wordpress.org/plugins/jetpack/

  2. Websiteguy
    Member
    Posted 7 months ago #

    To fix this you should download jetpack 2.4b2 version until the bug is fixed.

  3. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 7 months ago #

    Could you go to Posts > All Posts in your dashboard, click on one of the posts including a gallery, and switch to the Text editor in the top right corner? What's the gallery shortcode you see in the editor? Could you copy it, and paste it here?

    You will also want to go to Settings > Media in your dashboard, and make sure that you haven't checked the option enabling Tiled Galleries for all galleries on your site.

    Thanks!

  4. Nightcap
    Member
    Posted 7 months ago #

    Thank you for your response Jeremy. The gallery shortcode showing is: [gallery columns="2" ids="1144,1145"]

    When I go to Settings - Media the setting where you could determine which of the choices would be the default, when creating a gallery in a post, is no longer there?

    In the past I made "Tiled Mosaic" the default, but many times I chose to override it, depending on the number of pictures in a post, with "Thumbnail Grid" and that worked flawlessly.

    BTW This behavior started after the update last night.

    Grateful for your help!

  5. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 7 months ago #

    Could you change the shortcode to the following:

    [gallery type="thumbnails" columns="2" ids="1144,1145"]

    If it does help, I think I may have found the cause of the problem. I fixed this issue in this changeset, and the fix will be part of the next Jetpack release.

  6. Nightcap
    Member
    Posted 7 months ago #

    As by your request I changed the shortcode to [gallery type="thumbnails" columns="2" ids="1144,1145"] and voila, the thumbnails are there again.

    Great that you found the cause and that I could be of help tracing the problem. For now, changing the shortcode in a post will work fine until a new upgrade is available.

    Thank you very much for your quick response and help, I appreciate it tremendously.

Reply

You must log in to post.

About this Plugin

About this Topic