WordPress.org

Ready to get started?Download WordPress

Forums

[closed] Jetpack forcing mobile theme on desktop (6 posts)

  1. wwwaddell
    Member
    Posted 1 year ago #

    When surfing into my blog wwwaddell.com the Jetpack mobile theme is loaded even though I'm on a desktop computer. I can't figure out why!

    When I'm logged in and view my site or Reject the mobile theme the proper theme is shown.

    I've tried disabling Jetpack, renaming the plugin folder, - but that just results in the site shown without any styling.

    What's going on? Can't find any info online so far.

    It started yesterday. I was saving some Private posts not sure if that has anything to do with it, but arund that time it happened. Help!

  2. wwwaddell
    Member
    Posted 1 year ago #

    I have disabled the Jetpack mobile theme, but it is still interfering. Any assistance in this matter would be very welcome and appreciated! :)

  3. edsbali
    Member
    Posted 1 year ago #

    Same problem here.
    In one of my site sahamok.com, mobile theme always display in both mobile and desktop when mobile them is set to "Enable excerpts on front page and on archive pages"
    But in my other site dakayo.com act opposite. Mobile theme always display in both mobile and desktop when mobile theme is set to "Show full posts on front page and on archive pages"

  4. Jay Versluis
    Member
    Posted 1 year ago #

    Confirmed - I have the same problem on my site. I've tried switching from "full posts" to "excerpts", reloaded the page and all came good. Switching back to "full posts" still leaves the full site on my Desktop Safari... that has to be a bug.

  5. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    @Jay Versluis - this thread is 7 months old - so definitely not relevant to current version of JetPack. If you have a problem with JetPack, please start a new thread on the JetPack forum:

    http://wordpress.org/support/plugin/jetpack

  6. wavygravy
    Member
    Posted 8 months ago #

    Confirmed this is still an issue with the latest version of WP & Jetpack.

    I also had to switch to display excerpts rather than the full post since most of my posts commence with the featured image and the featured image is included when your browsing categories (hence they appear twice)
    (Would be nice to have the option to switch this off).

    Other threads suggest this is a caching problem and clearing the cache on WP Super Cache does appear to resolve the problem, but its a recurring issue, so it's not really a workaround - just a temporary fix.

Topic Closed

This topic has been closed to new replies.

About this Topic