WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Jetpack Deactivates my widgets page (45 posts)

  1. Vishy Moghan
    Member
    Posted 1 year ago #

    Hi
    I was advised to start my own thread on the above subject which seems to be troubling a few users.

    On our team site at http://phasma2.com, after updating to WP 3.6 and Jetpack 2.4, my widget page on the dashboard disappeared almost entirely and what little showed on the page was unresponsive, even the help and screen setting default buttons.

    After deactivating all plugins, nothing changed. Worse still Jetpack would show a 500 Error page every time I tried to deactivate it.

    Before that though I changed to the Twenty Thirteen theme and other default WP themes to see if the incompatibility was with my template (Aggregate by Elegant themes). This did nothing to alleviate the problem either.

    In the end I was forced to delete the plugin folder via FTP. This restored all my functions to normal.

    The site uses Jetpack mainly for the good social sharing package and stats control that it contains. These two functions are pretty integral to the way I manage the site. So understandably I would like to be able to re-install Jetpack.

    My Site is run on WP 3.6, always kept fully updated, my hosting service is on HUB Web hosting. Below is a list of all the plugins I have used in to date, and so far with older versions of Jetpack they have caused no issues to occur.

    Akismet
    Disable Comments
    Easing Slider "Pro"
    Elegant Builder
    Fullscreen Galleria
    Ninja Pages, Categories, and Tags
    No Right Click Images Plugin
    Revision Control
    Ultimate Tag Cloud Widget
    Yet Another Related Posts Plugin

    Addendum: I tried uploading an older version of Jetpack but this had the same result forcing me to delete this from my FTP too.

    http://wordpress.org/plugins/jetpack/

  2. Wastabik
    Member
    Posted 1 year ago #

    Same problem with me too and I'm also hosted at webhostinghub.com if Vishy means the same by HUB Web.Is this a problem related to our hosting?

  3. Vishy Moghan
    Member
    Posted 1 year ago #

    Same problem with me too and I'm also hosted at webhostinghub.com if Vishy means the same by HUB Web.Is this a problem related to our hosting?

    Hi Wastabik, yes I do... So is it perhaps a problem with their server?

    But one thing is for sure I have several other WP sites hosted there and they are not showing the same problem, and as I mention I have tried changing themes to default ones like Twenty Twelve etc. and it doesn't change the problem. Hmmmm!

  4. Tania
    Member
    Posted 1 year ago #

    Hi, I don't think its a hosting problem. I host on different server. When i updated Jetpack, I don'r have access to the widget page anymore. Plugin works perfectly, all my pages same as I designed using this plugin, but I can't do anything more, because I can't access the widgets page. When I deactivated Jetpack, widgets page working fine. It means that problem is with plugin. How to fix this? Please help. I like this plugin a lot.
    is there anything similar out there?

  5. Vishy Moghan
    Member
    Posted 1 year ago #

    Hmmm. It seems then that the problem is, as I thought from the start with Jetpack. As I have mentioned it doesn't seem to be an incompatibility with other plugins, since it still block functionality when it is the only plugin that is active.

    The ball I think is in the designer's of Jetpacks court now.

    Can we have a solution please. Otherwise we shall simply have to stop using Jetpack.

  6. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Hi all,

    Can you please add this line to your wp-config.php file?

    define('WP_DEBUG', true);

    This should show errors on your widget page which will help us to troubleshoot this. This may also cause PHP error notices to appear on the front of your site, depending on your theme and plugins. Please make note of the errors (both on the widget page and on the front-end, if applicable), and then remove the line from your wp-config.php file.

    Then, please contact us through our contact form here:

    http://jetpack.me/contact-support/

    Include the error messages, a link to your site, and a link to this thread.

    Thank you very much!

  7. Vishy Moghan
    Member
    Posted 1 year ago #

    Hi Richard

    Is there any reason to add this script to our config file since we have it seems already deactivated and deleted Jetpack? Obviously right now without the plugin our sites are functioning normally!

  8. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Vishy, the reason was to help you and us debug what the problem is. Of course, if you don't want to use Jetpack anymore, no problem, it's always up to you!

    If you still want to try to solve this, can you try deactivating the Subscriptions module and then check your widgets page again? We found that deactivating that module made the widgets page load properly with another user with the same symptoms; if we can confirm this with you, it'll help us to suggest a solution.

  9. Vishy Moghan
    Member
    Posted 1 year ago #

    Hi Richard
    Er I think you misconstrued my last writing. Of course I want Jetpack and in fact I need it for our site. My question was not a criticism of your request. I was simply wondering what use the script would be since, as I mentioned in my original post I had to delete Jetpack via FTP. And so the question was how will pasting the script into the site help if there is no Jetpack installed.

    But the thing with the subscriptions certainly sounds promising so I shall try it.

  10. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Great, Vishy, and yes, I did misunderstand your last post (darn text-based communication!)

    Let me know what happens if you deactivate the subscriptions module! Thanks!

  11. Vishy Moghan
    Member
    Posted 1 year ago #

    OK so here's what happened:

    I installed Jetpack again, and immediately lost my widgets page. Also there is no where I can deactivate Subscriptions as you suggest. Also again when I try to deactivate Jetpack from inside my dashboard, it takes me to an error 500 page. So I will have to go to my FTP and delete it from there again, otherwise the dysfunction of the site would be detrimental to the user experience. Sorry

  12. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    So, if you go to the Jetpack paghe, you should be able to deactivate the Subscriptions module by clicking the "Learn More" button, then a deactivate button will appear. Try that, if you're patient enough to go through all of it again. :)

  13. Daniel Lopez
    Member
    Posted 1 year ago #

    Hello everyone

    I have the same problem, failure of the widgets page with the latest update to Jetpack with an elegant theme (Magnificent in my case)

    But I can disable Jetpack from desktop plugins page.

    I tried disabling Photon and subscriptions, but the problem continues ...

    Thank you!

    D

  14. Vishy Moghan
    Member
    Posted 1 year ago #

    Hi again Richard
    So things get worse it seems. I think this business of deleting and reinstalling the plugin has done some damage in the whole set up. I just tried to re-install it and it sat the for ages on the installation page and then failed to install with this message:

    "The package could not be installed. PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature"

    Hmmmm. So I am somewhat lost now. In point of fact my entire dashboard is incredibly sluggish and non-responsive now!!! Help!

  15. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Vishy, compai, if you add this line to your wp-config.php file, it should fix it:

    define( 'JETPACK_CLIENT__HTTPS', 'NEVER' );

    Make sure to add it before this line:

    require_once(ABSPATH . 'wp-settings.php');

    Our devs think that the source of the issue may be that the wp_remote_get core function can't make requests to https URLs due to some misconfiguration on your servers. You should talk to your host to see if they can fix that.

    Also, Vishy, your latest issue shows me that your host and server has other issues. It may be vastly oversold and there may be other sites on that server that are using all the resources. You may want to consider changing hosts.

  16. Daniel Lopez
    Member
    Posted 1 year ago #

    Thanks Richard for your quick response.

    But I fear that after adding this line to wp-config, where you indicated, the problem continues and desktop widgets page does not work (column disappears from the right sidebar) and is no longer jetpack widgets that had in use

    By the way, I have sent the notices and warnings that appear when I try to enter the page of widgets.

    Thanks again

    D

  17. conservativeread
    Member
    Posted 1 year ago #

    same problem here hosted by hostgator dedicated server and using swift premium theme . maybe the problem is with the new widget visibility module ? swift theme has other users reporting this problem as well

    http://swiftthemes.com/forums/showthread.php?2153-Sidebar-and-menu-dissapears

  18. Tilley46
    Member
    Posted 1 year ago #

    I am having similar issues as well- use Standard Theme hosted on WHH. I also had to delete Jetpack via FTP, and when I reinstalled it through the WP Dashboard, I couldn't get Jetpack to link to WordPress- same 'Internal Server Error' msg. Same issues with widget page, same error msg when using the 'default template' vs. the 'full-width' template, same issue w/ menus disappearing, among other problems... Is there a way to re-load an older version of Jetpack while the bugs on the updated version are worked out? Please advise. Thx!

  19. Wastabik
    Member
    Posted 1 year ago #

    I deleted Jetpack again, waited for about a day, re-installed it via WordPress dashboard and deactivated the Subscriptions module as suggested.

    It worked!

    I'm not sure whether waiting for a day has any significance in this but you could try it out.

  20. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Hi folks,

    Wastabik: waiting for a day shouldn't have changed anything.

    Everyone else who is still having this issue: would you mind contacting us with FTP credentials for your site, so we can take a look? You can contact us here with the credentials:

    http://jetpack.me/contact-support/

    Make sure to include a link to this thread. Thanks!

  21. Vishy Moghan
    Member
    Posted 11 months ago #

    [Moderator Note: Please do not post in uppercase & shout at us. Post de-capped.]

    OK guys...

    an update on my progress.

    i reinstalled jetpack after pasting this script:
    define( ‘jetpack_client__https’, ‘never’ );
    as sent to me by richard in my wp-config.

    this did not cure the problem.

    but i went into the jetpack control panel and deactivated every module apart from the three i need which are stats,publicize and sharing.

    after this my widgets page returned to normal and thus far i see no new problems arising. i shall post here again if there are any new developments.

    however i do suspect that json api was the culprit. not interested enough in those, nor technically adept enough to look into it to see which exactly was blocking. it seems though the obvious new 'widget visibility' module in fact was not the problem.

    thanks all.

  22. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 11 months ago #

    We suspect the subscriptions widget on some hosting configurations, Vishy.

    You say that the define( ‘jetpack_client__https’, ‘never’ ); didn't work for you? Did you leave that line in? If yes, what happens when you activate the subscription module?

  23. Vishy Moghan
    Member
    Posted 11 months ago #

    Hi Richard
    Yes the script is still there. But I'm afraid I have more bad news. I made my first posting since installing Jetpack afresh tonight. I wrote the post and it was all shipshape and ready to go. But every time I hit the publish button, I find myself on the dread ERROR 500 page.

    As I mention above there are only three active modules on Jetpack there... Sharing, Publicize and Stats, which by the way are all working OK as far as that goes. My widget page is back but I have not tried adding or taking anything off it yet.

    Anyway are there any other possibilities?

  24. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 11 months ago #

    Vishy, I just had a look at your wp-config.php file, since you sent us FTP credentials. Could you move the define( ‘jetpack_client__https’, ‘never’ ); line to before where it says /* That's all, stop editing! Happy blogging. */ ? That might fix it. Try that and let me know.

  25. Vishy Moghan
    Member
    Posted 11 months ago #

    Hi Richard

    Nope, done and it still takes e to the ERROR 500 page. I will meanwhile contact the tech people on my server and see what they can do, although to be blunt and frank they have mostly proved useless.

    Please let me know of any developments. Thanks.

  26. Wastabik
    Member
    Posted 11 months ago #

    I thought I ought to chime in here. It could be helpful to the developers of this grand plugin.
    I deactivated the Subscription module and got back my widgets page.I haven't reactivated it and neither have I included the ( ‘jetpack_client__https’, ‘never’ ) anywhere.

    The reason I cut in here could be related with Vishy's Error 500 page and Jetpack, and hence related with this thread. I haven't uploaded any new plugins but I've updated WordPress to its latest version. But I get a 404 error every time I hit the Update or Publish button.

    If my problem is not related to this thread, please excuse me for my ignorance.

  27. Vishy Moghan
    Member
    Posted 11 months ago #

    Oh hi Wastabik. Thanks for the input. I do think and have thought from the start that your problem and mine are pretty much exactly along the same lines.

    I have generally tried all sorts of things and the only thing that really works for getting my system under control is deleting Jetpack altogether. Once that is done everything behaves normally.

    Meanwhile I have also been unto my server/host tech staff and they tell me that the problem is with the post-new.php! They checked back on their error reports and sent me this report:

    [Wed Sep 25 09:05:51 2013] [error] [client 216.54.31.86] Premature end of script headers: post.php, referer: http://phasma2.com/wp-admin/post-new.php

    Now to me this tells me nothing whatsoever but maybe you better brains here can tell me what my next step is, if I am to keep Jetpack installed.

    I really do not have the technical knowledge it would take to troubleshoot this.

    Thanks all.

  28. Vishy Moghan
    Member
    Posted 11 months ago #

    OK all here

    So finally I went back and deleted Jetpack again and the entire problem with ERROR 500 ages and so on disappeared completely and the site is behaving normally again.

    I hope that the programmers and designers of this very useful plugin can find their way around the problem. For now I shall resort to other plugins for my Stats and social media needs. Shame.

  29. Wastabik
    Member
    Posted 11 months ago #

    That's a nice decision Vishy. As for me, the error 404 isn't a great nuisance because when I refresh the page whatever I've updated or published gets PUBLISHED. If I had been suffering like you, I'd have kicked Jetpack ages ago... I'm going to stay around.
    But, I love this plugin and so do you.
    So, whenever a stable version comes around, I'll inform you.
    Cheers.

  30. Vishy Moghan
    Member
    Posted 11 months ago #

    Thanks Wastabik

    I think the best thing about Jetpack is that it puts every thing in one easy to manage package and their stats are so simple and useful.

    And yes with my site too every time I refresh it has done what I had wanted, but the problem with this site is that it is a multi user site, and therefore some of the other guys that post there would be very lost and confused if they keep getting error messages. So I had to, regretfully take it off.

    I look forward to hearing from you. Cheers.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic