WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Jetpack Contact Form sends Multiple Emails (14 posts)

  1. Evangeline Holland
    Member
    Posted 1 year ago #

    The title, I hope, is self explanatory. Ever since I implemented this into my website, I've received more than one email. Until today, I received two emails, but now I am receiving four. Is there anything that can be done, or should I deactivate this service and use an individual plugin? Thanks!

    http://edwardianpromenade.com

    http://wordpress.org/extend/plugins/jetpack/

  2. Sheri Bigelow (designsimply)
    Member
    Plugin Contributor

    Posted 1 year ago #

    Can you please make sure you have updated to Jetpack 2.0 (the latest version) to see if that resolves the problem?

    If anyone else is experiencing this issue, please post a note here if you see this message.

  3. DrWig
    Member
    Posted 1 year ago #

    I receive between 10 and 60(!) emails for one send of the contact form on my site. It takes an age to actually send from the site, and sometimes just gives an error:
    http://www.littlechester.org.uk/?page_id=142

  4. DrWig
    Member
    Posted 1 year ago #

    Using latest jetpack etc.. (2.1.2)

    cheers

    DrWig

  5. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @DrWig

    When looking at the Feedbacks menu in your dashboard, does the email appear multiple times there as well?

  6. DrWig
    Member
    Posted 1 year ago #

    Never spotted that item in the panel before! It's in there multiple times as well.......

  7. DrWig
    Member
    Posted 1 year ago #

    each item with a few seconds between them....

  8. DrWig
    Member
    Posted 1 year ago #

    For example (some bits removed!)
    Select DrWig – 2013-02-06 10:19:32 2013-02-06 @ 10:19:32 AM
    Select DrWig – 2013-02-06 10:19:30 2013-02-06 @ 10:19:30 AM
    Select DrWig – 2013-02-06 10:19:24 2013-02-06 @ 10:19:24 AM
    Select DrWig – 2013-02-06 10:19:22 2013-02-06 @ 10:19:22 AM
    Select DrWig – 2013-02-06 10:19:21 2013-02-06 @ 10:19:21 AM
    Select DrWig – 2013-02-06 10:19:16 2013-02-06 @ 10:19:16 AM
    Select DrWig – 2013-02-06 10:19:13 2013-02-06 @ 10:19:13 AM
    Select DrWig – 2013-02-06 10:19:11 2013-02-06 @ 10:19:11 AM
    Select DrWig – 2013-02-06 10:19:10 2013-02-06 @ 10:19:10 AM
    Select DrWig – 2013-02-06 10:19:08 2013-02-06 @ 10:19:08 AM
    Select DrWig – 2013-02-06 10:19:07 2013-02-06 @ 10:19:07 AM
    Select DrWig – 2013-02-06 10:19:05 2013-02-06 @ 10:19:05 AM
    Select DrWig – 2013-02-06 10:19:04 2013-02-06 @ 10:19:04 AM
    Select DrWig – 2013-02-06 10:19:02 2013-02-06 @ 10:19:02 AM
    Select DrWig – 2013-02-06 10:19:01 2013-02-06 @ 10:19:01 AM
    Select DrWig – 2013-02-06 10:18:59 2013-02-06 @ 10:18:59 AM
    Select DrWig – 2013-02-06 10:18:57 2013-02-06 @ 10:18:57 AM
    Select DrWig – 2013-02-06 10:18:56 2013-02-06 @ 10:18:56 AM
    Select DrWig – 2013-02-06 10:18:54 2013-02-06 @ 10:18:54 AM
    ...

  9. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Could you try to deactivate all other plugins, one at a time, to check if one of them causes the Contact Form to be submitted multiple times?

    A caching plugin could for example be what's causing the issue.

  10. DrWig
    Member
    Posted 1 year ago #

    ok. I have very few on the site. Currently:

    Jetpack
    Akismet
    Google Analyticator

    cheers

    DrWig

  11. DrWig
    Member
    Posted 1 year ago #

    disabling the other two plugins doesn't help/......

    Also, when the form finally finishes, it gives me this page:

    CGI Error
    The specified CGI application misbehaved by not returning a complete set of HTTP headers.

    cheers

    DrWig

  12. DrWig
    Member
    Posted 1 year ago #

    Last one sent over 100 emails to me!

  13. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Also, when the form finally finishes, it gives me this page:

    CGI Error
    The specified CGI application misbehaved by not returning a complete set of HTTP headers.

    Thanks for providing more details about your problem, that's helpful!

    This problem seems to be linked to your server configuration, and not to WordPress and Jetpack:
    http://support.microsoft.com/kb/145661
    http://perlmonks.org/?node_id=165253

    Could you contact your hosting provider, and ask them to have a look at the issue? They should be able to fix this for you.

  14. DrWig
    Member
    Posted 1 year ago #

    ah, ok. Many thanks for that. As everything else was working fine, and I'd found some others with similar issues, I thought it might be Jetpack.

    Thanks for your input :-)

    cheers

    DrWig

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic