WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Jetpack conflict with WordPress SEO (yoast) (3 posts)

  1. Mijke82
    Member
    Posted 8 months ago #

    Jetpack seems to have a problem with WordPress SEO by Yoast. When both activated I receive the 'white screen of death' when logging in as an editor on wp-admin. This problem occurred earlier on the administrator wp-panel as well, but after deactivating all plugins and then activating them again the problem was solved. But the problem still exists for my other users that have a little less rights then me. This is most inconvenient.

    I would very much like to continue using the SEO plugin as well as Jetpack, so I've looked up documentation of this problem and it seems the problem lies in both plugins using open graph or something? I'm new at wordpress, so I would like to receive an easy fix. Also, if this problem is a known problem, why hasn't anything been done to resolve this?

    http://wordpress.org/plugins/jetpack/

  2. Mijke82
    Member
    Posted 8 months ago #

    Also, the errors in the error log mainly have jetpack in them... none of them say there's something wrong with the WordPress SEO plugin. So that is why I'm asking this question on this support page.

    A few examples of errors:

    [Fri Nov 22 23:29:16 2013] [error] [client 46.129.27.243] FastCGI: server "/usr/local/php52/bin/php-cgi" stderr: PHP Warning: Missing argument 1 for is_wp_error(), called in /sites/harlemoil.nl/www/wp-content/plugins/jetpack/modules/videopress/videopress.php on line 127 and defined in /sites/harlemoil.nl/www/wp-includes/class-wp-error.php on line 204

    [Fri Nov 22 23:30:41 2013] [error] [client 46.129.27.243] FastCGI: server "/usr/local/php52/bin/php-cgi" stderr: PHP Warning: ignore_user_abort() has been disabled for security reasons in /sites/harlemoil.nl/www/wp-content/plugins/jetpack/class.jetpack-sync.php on line 77, referer: http://harlemoil.nl/wp-admin/admin.php?page=jetpack

    [Fri Nov 22 23:30:41 2013] [error] [client 46.129.27.243] FastCGI: server "/usr/local/php52/bin/php-cgi" stderr: PHP Warning: ignore_user_abort() has been disabled for security reasons in /sites/harlemoil.nl/www/wp-content/plugins/jetpack/class.jetpack.php on line 3481, referer: http://harlemoil.nl/wp-admin/admin.php?page=jetpack

  3. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 8 months ago #

    I would very much like to continue using the SEO plugin as well as Jetpack, so I've looked up documentation of this problem and it seems the problem lies in both plugins using open graph or something?

    The errors you mentioned in your last post do not seem to be related to the WordPress SEO plugin.
    I believe the Open Graph conflict you're referring to was fixed a year ago.

    It does seem, however, that the problem lies with your server configuration. Jetpack uses the ignore_user_abort function, but your host has decided to disable it on your server.

    You should be able to fix this issue by making a change in your server's php.ini file. Most hosting providers don't allow you to edit this file yourself, but they should be able to edit this file for you.
    Could you get in touch with them, and ask them to remove the ignore_user_abort string from disable_functions in your server's php.ini file?

    It might also solve the issues you've experienced with the WP SEO plugin.

    Let me know if it helps.

Reply

You must log in to post.

About this Plugin

About this Topic