WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
Jetpack Comments - Text box expand with every character (3 posts)

  1. yotis
    Member
    Posted 1 year ago #

    I really enjoy using Jetpack plugin, but right now I have an issue with the Comments.

    Problem is that the text box (where you input your comment) is expanding with every character. It works fine on the first page (home page of the blog) but not on the other.

    Check it here if you don't understand what I mean:
    http://blogwithphotos.net/stairs-to-dawn/
    There is Comment button under the photo. Try to type some comment and you'll see what's happening.

    You'll see that if you're going to the main page http://blogwithphotos.net is working fine.

    Maybe it has something (as is working on the homepage) to do with the following code in the functions.php:

    function gpp_comment_toggle_script() {
    $doc_ready_script = '
    <script type="text/javascript">
    jQuery(document).ready(function(){
    jQuery( ".comments-link a" ).click( function(e){
    ';
    //Homepage doesnot need preventDefault and single page does
    if(!is_home()){
    $doc_ready_script .= 'e.preventDefault();';
    }

    $doc_ready_script .= '
    if (jQuery("#comments").is(":visible")) {
    jQuery( "#comments" ).slideUp( 500 );
    } else {
    jQuery( "#comments" ).slideDown( 500 ).scrollView();
    }
    });';

    /* lazy loader for archive page */
    if(is_page_template('page-archive.php')){
    $doc_ready_script .= 'jQuery("pre.lazy").lazyLoad();';
    }
    $doc_ready_script .= '
    });
    </script>';
    echo $doc_ready_script;

    }

    I tried already to disable all plugins, but does not help. I assume that there is somekind of JS conflict, but I cannot really figure it out what.

    Any help will be appreciated.

    Thank you!

    http://wordpress.org/extend/plugins/jetpack/

  2. Howdy, I'll be happy to take a look.

    What browser and version are you using?

    I've tested this with the post you've linked to using an Incognito window with Google Chrome 23.0.1271.101 and I wasn't able to reproduce your description.

    If you're using Mozilla Firefox, could you please try it in Safe Mode to narrow down a browser–specific issue?

  3. yotis
    Member
    Posted 1 year ago #

    Hello Bryan,

    Thanks for taking the time to look into my issue.
    I did test with all browsers which I have installed: Safari, Google Chrome, Firefox (with and without privacy mode enable). All have the same issues.

    I did a little screencast to show you: http://screenr.com/BPW7

    If you check my screencast you'll see that Chrome / Safari start to expand the box like crazy only after 5-6 words. Firefox instead starts immediately.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic