WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Jetpack comment submission leads to 404 error (11 posts)

  1. theonetruebix
    Member
    Posted 1 year ago #

    Had someone inform me this morning that they posted a comment to a post of mine overnight and it didn't appear. According to them, they'd signed in with their WordPress account, typed a comment, hit post, and... nothing. It's definitely not posted, not in moderation, and not in spam.

    I can reproduce the problem, and determined why, sort of. Upon hitting post, the Jetpack comments iframe refreshes to... a page that's a 404 error.

    It goes to

    http://furiousnads.com/wp-comments-post.php?for=jetpack

    which doesn't work, because it should be wordpress/wp-comments-post.php?for=jetpack

    If I disable Jetpack comments, native WordPress commenting functions fine. So, it's something about Jetpack comments being active.

    None of the other various threads about this problem -- which seems to crop up every few months? -- leads to a solution for me. I've no idea how long the problem has been around; the last comment I have on the site is from January 2, but I have no idea if anyone's tried to post one between then and today.

    http://wordpress.org/extend/plugins/jetpack/

  2. theonetruebix
    Member
    Posted 1 year ago #

    FWIW, I just checked some logs and the incorrect wp-comments-post.php URL has been encountered since Sunday, January 6. So there's the timeframe. What changed on January 6 regarding Jetpack?

  3. Christopher Finke
    Design Engineer at Automattic
    Plugin Author

    Posted 1 year ago #

    Thanks for the report; I was able to reproduce the problem on your blog as well. Would you mind posting a screenshot of the top portion of your Settings > General page? Specifically, the "WordPress Address (URL)" and "Site Address (URL)" settings. If you don't want to post a screenshot, you could paste the values for those two settings.

  4. theonetruebix
    Member
    Posted 1 year ago #

    WordPress Address (URL) http://furiousnads.com/wordpress
    Site Address (URL) http://furiousnads.com

  5. Christopher Finke
    Design Engineer at Automattic
    Plugin Author

    Posted 1 year ago #

    While I'm working on this, can you try disconnecting and reconnecting to WordPress.com from the Jetpack dashboard?

  6. theonetruebix
    Member
    Posted 1 year ago #

    Just did that now. And now comments work.

  7. Christopher Finke
    Design Engineer at Automattic
    Plugin Author

    Posted 1 year ago #

    That's great!

    Did you recently change the way your WordPress installation is set up? Or has it been in a wordpress/ subdirectory for a long time? For some reason, Jetpack had your WordPress URL as just "http://furiousnads.com" instead of "http://furiousnads.com/wordpress", so I'll need to figure out why that happened.

  8. theonetruebix
    Member
    Posted 1 year ago #

    It's been /wordpress since this install in late December. And people had posted comments back on January 1 and January 2.

  9. Christopher Finke
    Design Engineer at Automattic
    Plugin Author

    Posted 1 year ago #

    Ok; thanks for your help.

  10. matthewkotze85
    Member
    Posted 8 months ago #

    Hi. I am having a very similar issue.
    site address is http://www.uncleartmusic.com

    WP was in a different folder originally, however I'm pretty sure by the time I had installed jetpack I had migrated it over to the root folder.

    Normal comments work fine without jetpack.
    However when I click submit, if I'm logged in as admin. Its brings up, what looks like my homepage. If I'm not logged in, its brings up 404.

    Any help would be much appreciated, as I really do prefer the jetpack comments!

  11. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 8 months ago #

    @matthewkotze85 Could you please start your own thread, as per the Forum Welcome?
    http://wordpress.org/support/plugin/jetpack#postform

    Thank you!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic