WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Jetpack can't connect to wordpress.com from a site hosted at dreamhost (11 posts)

  1. dtradd
    Member
    Posted 4 months ago #

    Hi everyone,

    A couple of days ago, I installed a wordpress blog using my dreamhost hosting. I tried activating jetpack but I keep getting this error message:

    Jetpack could not contact WordPress.com: register_http_request_failed. This usually means something is incorrectly configured on your web host. connect() timed out!

    I've been browsing the forum and have found some workarounds for earlier versions, but I couldn't manage to get it working. I only have another plugin active, akismet, but deactivating it hasn't sorted out the problem. This is the output from running jetpack compatibility test

    SITE_URL: http://www.40-semanas.org
    HOME_URL: http://www.40-semanas.org
    TEST: HTTP Connection
    
    WP_Error Object
    (
        [errors] => Array
            (
                [http_request_failed] => Array
                    (
                        [0] => connect() timed out!
                    )
    
            )
    
        [error_data] => Array
            (
            )
    
    )
    TEST: HTTPS Connection
    
    WP_Error Object
    (
        [errors] => Array
            (
                [http_request_failed] => Array
                    (
                        [0] => connect() timed out!
                    )
    
            )
    
        [error_data] => Array
            (
            )
    
    )
    TEST: Self Connection
    
    Array
    (
        [headers] => Array
            (
                [date] => Tue, 11 Mar 2014 16:49:35 GMT
                [server] => Apache
                [vary] => Accept-Encoding
                [content-length] => 42
                [connection] => close
                [content-type] => text/plain
            )
    
        [body] => XML-RPC server accepts POST requests only.
        [response] => Array
            (
                [code] => 200
                [message] => OK
            )
    
        [cookies] => Array
            (
            )
    
        [filename] =>
    )

    Thanks in advance for your help

    https://wordpress.org/plugins/jetpack/

  2. namhuy
    Member
    Posted 4 months ago #

    I have the same problem with Nam Huy Linux http://namhuy.net

    I'm on a VPS which I can control everything. iptables IN/OUT/FORW are ACCEPT everything.

    php_value allow_url_fopen On

    Akismet can verify my API but I can't connect to Akismet servers :(

  3. namhuy
    Member
    Posted 4 months ago #

    update... i didnt change anything and akismet magically works now :)

  4. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 4 months ago #

    Hi dtradd,

    Cute site, and congrats! :)

    I'm not sure why you have this error, but something seems to be preventing the connection to WordPress.com. Can you please use Jetpack's Debugger module to send us some more information about your site? The report will look similar to what you posted, but will have additional information.

    1) Go to the Jetpack page in your dashboard.
    2) Click on "Help" tab in the upper right side of the page and click the link for "Jetpack Debugging Center."
    3) Click the link that says "click here to contact Jetpack support."
    4) Fill in the description box and your name and email address.
    5) Click the "Contact Support" button.

    Thanks!

  5. dtradd
    Member
    Posted 4 months ago #

    Hi Richard,

    Thank you for your reply and your congrats!

    When I click in the link for "Jetpack Debuggin Center" I find a page that says the following:

    Your site isn’t reaching the Jetpack servers.
    
    HTTP:
    	connect() timed out!
    
    Your site isn’t securely reaching the Jetpack servers.
    
    HTTPS:
    	connect() timed out!
    
    It looks like your site can not communicate properly with Jetpack.
    
    SELF:
    	connect() timed out!

    but I can't find a link which says "click here to contact Jetpack
    support"

    Do you think I should ask the people at Dreamhost about this problem?

    Thanks!

  6. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 4 months ago #

    Yes, as I'm note sure what the issue is. If I try the following command in terminal:

    curl -i -H 'Content-Type: text/xml' --data '<?xml version="1.0"?><methodCall><methodName>demo.sayHello</methodName><params></params></methodCall>' 'http://www.40-semanas.org/xmlrpc.php' && echo

    I get the right and expected result. I do have one suspicion, though. If I try that same command, but without the http://www., I get a 301 - Moved Permanently message, pointing to the www. version of the URL. I see that you have your Home and Site URL values set to use the www so I don't know why it'd give an error, though. So, yes, contact Dreamhost and point them to this thread, and let me know what they say.

  7. dtradd
    Member
    Posted 4 months ago #

    It's sorted now. I sent an email to Dreamhost and although they haven't replied, I just activated Jetpack properly. Once they tell me what they've done I'll post it here and mark the topic as solved.

    Thanks, Richard!

  8. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 4 months ago #

    Hey, great! I can confirm that you are now in fact properly connected to WordPress.com. Glad they sorted it out for you, and I am definitely interested by what they did to fix it, so thanks in advance for updating me!

  9. dtradd
    Member
    Posted 4 months ago #

    Hi,

    This is the official response from Dreamhost. I hope it's useful for some other people who are stuck with this issue:

    Hello,

    I sincerely apologize for the delayed response. We have a large amount of
    incoming support and it's taking longer than usual to get through it all.
    But to connect to Jetpack you just need to raise your execution time.
    Since your site is running on PHP 5.3, all you need to do is log into
    your FTP account. Then under your username directory (not the domain
    directory) create a folder named /.php. In that folder create another
    named /5.3. In that folder, create a text file called phprc (without an
    extension). In that file you can add any commands you like such as these:

    max_execution_time = 500
    max_input_time = 500

    Once setup you'll be able to connect. Please let us know if you have any
    further questions.

  10. namhuy
    Member
    Posted 3 months ago #

    this is what i use for akismet

    iptables -A OUTPUT -p tcp -d AKISMET_IPS --dport 80 -j ACCEPT

    for many days testing, it's not about iptables or firewall, akismet takes time to scan or access your website. In my case Akismet can verify my API but I can't connect to Akismet servers. Don't worry, it may takes hours for Akismet to re-verify connection to your website as long as they can verify API.

  11. BrianRaider
    Member
    Posted 2 months ago #

    Hello Richard,
    I had jetpack working fine on my site untill the admin who installed it was accidently taken off admin status and now jetpack doesnt work. I delted the plugin and downloaded it new aND REINSTALLED however this is all it keeps saying:To enable all of the Jetpack features you’ll need to connect your website to WordPress.com using the button to the right. Once you’ve made the connection you’ll activate all the delightful features below.
    Connect to WordPress.com
    When I clickon connect it just brings me to my homepage???

Reply

You must log in to post.

About this Plugin

About this Topic