WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Jetpack 2.0.4 upgrade breaks several plugins (9 posts)

  1. ssiddiqi1
    Member
    Posted 1 year ago #

    Jetpack v 2.0.4 broke several plugins. SI Captch, reCaptcha and Events Espresso Pro. Si Capatch and reCaptcha do show captcha images but typing the captcha words give error "captcha words you typed was wrong" Events Espresso encountered several problems, (1) it members registration broke, (2) payment system charged double amount from customers. It was the biggest catastrophe after upgrading to v2.0.4 of Jetpack. I downgraded to Jetpack 2.0.2 and everything started behaving.

    http://wordpress.org/extend/plugins/jetpack/

  2. Mike Challis
    Member
    Posted 1 year ago #

    I am the author of SI CAPTCHA Anti-Spam

    Disable Jetpack sharing module, did the problem go away?

    Let me know

    Mike

  3. ssiddiqi1
    Member
    Posted 1 year ago #

    No. Sharing module was always disabled. But downgrading the Jetpack 2.0.2 does solve problems.

  4. Josh
    Member
    Posted 1 year ago #

    Hi there,

    With Event Espresso Pro, it appears that the conflict will only manifest itself if both the Publicize and Sharing modules are active. When either of these modules are active, opengraph tags get added to the head of the document, which seems to be causing the trouble.

    These modules can be deactivated on the main Jetpack settings page by clicking the Learn more button, then clicking the Deactivate button that appears to the right of the Learn more button.

    If you'd prefer to use either of these modules, you can disable the opengraph tags by adding a function like this to a custom functionality plugin -or- if you have Event Espresso's custom files add-on installed, you can add it to the custom_functions.php file:

    function disable_jetpack_og_on_regpage() {
    	if ( is_page(4) ) {
    		remove_action( 'wp_head', 'jetpack_og_tags' );
    	}
    }
    add_action( 'template_redirect', 'disable_jetpack_og_on_regpage' );

    In the above code example, the main registration page as set in Event Espresso>General Settings has the ID of 4. You'll need to swap out the page ID value with the one that's set on your site.

    I've submitted a ticket to the Event Espresso developers so they aware of the issue.

  5. Ian Dunn
    Member
    Posted 1 year ago #

    It also breaks the [bgmp-map] shortcode in the latest RC of Basic Google Maps Placemarks. I haven't pinpointed the source of the problem yet, but it looks like the shortcode is completely removed from $content when apply_filters( 'the_content', $content ); is run in the_content(). Disabling the Publicize and Sharing modules makes it work again.

  6. Ian Dunn
    Member
    Posted 1 year ago #

    Timperator discovered that this is a bug in Jetpack and posted a workaround until Automattic fixes it.

  7. Samuel Wood (Otto)
    Tech Ninja
    Posted 1 year ago #

    In fact, this is not a bug in Jetpack, it's a bug in the conflicting plugin. Show me the plugin that it breaks and I will show you how that plugin is doing-it-wrong. Guaranteed.

    More information on the underlying problem:
    http://ottopress.com/2011/actions-and-filters-are-not-the-same-thing/

  8. Ian Dunn
    Member
    Posted 1 year ago #

    With BGMP, the shortcode is properly returning output instead of echoing it. If you see something I'm doing wrong, I'll be happy to fix it.

    -----

    Er, nevermind, I just saw your post on wp-hackers. I'll reply over there.

  9. Ian Dunn
    Member
    Posted 1 year ago #

    For anyone else who runs into a similar problem, reading Otto's post on wp-hackers might be helpful.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic