WordPress.org

Ready to get started?Download WordPress

Forums

Javascript Errors (forbidden by X-Frame-Options) (14 posts)

  1. David Ollenberger
    Member
    Posted 1 year ago #

    I recently upgraded a few development installations to version 3.4.2 and they all have javascript errors that are killing some of the functionality (sliders, scrollers, etc...) that are based in jQuery / Javascript.

    I have disabled all plugins and set the theme to Twenty Eleven and still the same issue. Seems like it's a bug in version 3.4.2.

    Anyone else have the same issue?

    Thanks

  2. David Ollenberger
    Member
    Posted 1 year ago #

    As a follow up here are some of the other JS errors that are getting triggered on the site. Seems like there is a bad JS library in 3.4.2 somewhere:

    Uncaught TypeError: Cannot call method 'appendChild' of undefined assets.pinterest.com/js/pinit.js:22
    Uncaught SyntaxError: Unexpected token } events-manager.js:615
    Uncaught SyntaxError: Unexpected end of input bootstrap.min.js:7
    Uncaught SyntaxError: Unexpected identifier jquery.flexslider-min.js:37
    Uncaught TypeError: Object [object Object] has no method 'flexslider'
    Refused to display document because display forbidden by X-Frame-Options.

    I am using the Pinterest JS for sharing, Events Manager plugin, Twitter Bootstrap and Flexslider. These were all working perfectly up until the upgrade.

    Just to clarify, I have disabled all plugins and changed the theme to Twenty Eleven and still having issues. Also, I have individually removed the other libraries in my theme and made sure it's not one of theme causing issues.

  3. Andrew
    Forum Moderator
    Posted 1 year ago #

    What are the JavaScript errors once you've displayed all plugins and changed theme to Twenty Eleven?

  4. David Ollenberger
    Member
    Posted 1 year ago #

    I just get the one error:

    Refused to display document because display forbidden by X-Frame-Options.

    I am getting similar errors on several development installs on my server. Only the ones that have been upgraded to 3.4.2. I am using Hostgator but I have never had this issue before until the upgrade.

  5. David Ollenberger
    Member
    Posted 1 year ago #

    That is in Chrome developer tools. In FireFox using FireBug I get the following errors when the plugins and theme is activated:

    TypeError: a.d.b is undefined pinit.js (line 22)
    SyntaxError: missing ) after argument list events...r=3.4.2 (line 615, col 3)
    SyntaxError: missing } after function body bootstrap.min.js (line 7, col 60)
    SyntaxError: missing ; before statement jquery...-min.js (line 37, col 60)
    TypeError: jQuery(".flexslider").flexslider is not a function

  6. David Ollenberger
    Member
    Posted 1 year ago #

    It's not the latest version of jQuery because that was released back in September...

  7. esmi
    Forum Moderator
    Posted 1 year ago #

    SyntaxError: missing } after function body bootstrap.min.js (line 7, col 60)

    This one appears to be specific to the bootstrap theme?

    TypeError: jQuery(".flexslider").flexslider is not a function

    And this could be a plugin.

  8. David Ollenberger
    Member
    Posted 1 year ago #

    One would normally think that but everything was working as of 2 days ago. I use the bootstrap library and flexslider on several other sites and never had issues. Only the sites that are upgraded to version 3.4.2 of WordPress are presenting these errors.

  9. esmi
    Forum Moderator
    Posted 1 year ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  10. David Ollenberger
    Member
    Posted 1 year ago #

    Yes, I said in my initial post that I have disabled all plugins and switched to Twenty Eleven. Of course when I switch to Twenty Eleven I don't get all the errors I did before because the JS libraries I am using aren't in that theme but I still do see this in the error console:

    Refused to display document because display forbidden by X-Frame-Options.

    I also renamed the plugins folder via FTP to make sure it wasn't that but the issue persists.

    Again, let me make this clear. This site was working PERFECTLY two days ago. After the update to 3.4.2 all these errors appeared. I am a developer who has been working with WordPress for years and I develop on WordPress everyday. I just need to know if there is a bug in 3.4.2 because this issue is persisting across multiple sites today.

  11. esmi
    Forum Moderator
    Posted 1 year ago #

    when I switch to Twenty Eleven I don't get all the errors I did before because the JS libraries I am using aren't in that theme

    Then it sounds like you have a theme problem. Where did you download this theme from?

  12. David Ollenberger
    Member
    Posted 1 year ago #

    It's not a theme issue. I am a theme developer and this is a custom built theme from scratch. Again, this was working without any issues whatsoever just two days ago. I use just a handful of selected JS libraries in my themes that have always worked up until now.

    Either this latest version of WordPress has a bad JS library or a version of one of the included libraries is causing issues. I can't see whatelse it can be because it is persisting across multiple installations of the same version.

  13. esmi
    Forum Moderator
    Posted 1 year ago #

    this is a custom built theme
    [...]
    I use just a handful of selected JS libraries

    Since the issue is specific to your custom theme, that suggests that it is the theme that is responsible. No one else seems to be having the same problems. Even people using their own custom themes.

  14. David Ollenberger
    Member
    Posted 1 year ago #

    Thanks for your help but something is causing an issue because it was working fine 2 days ago and now it's not and I haven't updated anything else in the theme. I'll sort this out on my own from here.

Topic Closed

This topic has been closed to new replies.

About this Topic