WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery Voting
Javascript error when edit a gallery (4 posts)

  1. abmcr
    Member
    Posted 2 years ago #

    I have used a clean installation of the plugin and the last nextgen gallery , 1.8.2

    I create a gallery and, when i edit it, the voting plugin js create an error

    nggv_enable is not defined
    str += "<input type='checkbox' nam...nable voting for this gallery
    ";

    line 13 of gallery_options.js

  2. shauno
    Member
    Plugin Author

    Posted 2 years ago #

    Hey

    I've just checked on a clean WP 3.2.1 installation, with NGG 1.8.3, and NGGV 1.8.2, and I don't get any javascript errors.

    Can you explain the exact process you go through to get the error
    Example:

    • Click on 'Add Gallery / Images'
    • Click 'Add new gallery
    • Type in name
    • etc

    What default gallery voting options do you have set?
    Also, what version of what browser are you using?

    Can anyone else confirm getting the same (or similar) JS error?

  3. abmcr
    Member
    Posted 2 years ago #

    The error appears only if the gallery have no photos..... i apologize for the post; i think this is not important, because if gallery is empty, it is no rating :-)

  4. shauno
    Member
    Plugin Author

    Posted 2 years ago #

    Ah yes, makes sense.

    There is a legacy problem with the plugin that requires there to be an image with a custom field to get the gallery options working.
    This is because there was no way to hook into the gallery when I wrote the plugin.
    I'm not sure if there is a way now, but I'm not too keen to go digging through that code and start messing with it when it's got so many live installations right now.

    But thanks for the feedback, it's always a help getting constructive comments!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic