WordPress.org

Ready to get started?Download WordPress

Forums

I've been getting the same error every few weeks. (3 posts)

  1. brownkidd
    Member
    Posted 5 years ago #

    I'm not sure what's going on here, but I've been getting the same error every few weeks for several months now. It usually starts off with a 403 error and when I call my web host, they say that the index.php file is missing. I'm not sure how that could happen since I'm the only one with the password to my ftp.

    No biggie. Just re-upload the index.php file from a backup. Only problem is, I get this:

    Warning: require(./wp-blog-header.php) [function.require]: failed to open stream: No such file or directory in /homepages/46/d255400443/htdocs/albotasblog/index.php on line 17

    Fatal error: require() [function.require]: Failed opening required './wp-blog-header.php' (include_path='.:/usr/lib/php5') in /homepages/46/d255400443/htdocs/albotasblog/index.php on line 17

    Looks like the wp-blog-header.php file is missing. When I replace it, I get another error stating that another file is missing and when I upload the file I get another error and so on.

    It seems like this happens at least once or twice a month and I'd just like to know what could be causing it and how to prevent it.

  2. hotkee
    Member
    Posted 5 years ago #

    If you have been upgrading, perhaps the upgrade didnt happen properly.

    Or you might have given permission to someone else who is removing the files ... hacker?

    Change your password completely for a start to something very secure, ensure no one else has access. And do a complete check of the files or refresh the files.

    Still not fixed - then change host if they cant tell whats going on.

  3. brownkidd
    Member
    Posted 5 years ago #

    Thanks. A lot of people have been telling me to change hosts so it looks like that's my best option at this point.

Topic Closed

This topic has been closed to new replies.

About this Topic