WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Logging Service
Items not deleted (6 posts)

  1. evilimp
    Member
    Posted 1 year ago #

    Under Dashboard / System Logs, if I select an item (or items), then on the dropdown menu choose Delete, then the Apply button, the item doesn't delete.

    http://wordpress.org/extend/plugins/wordpress-logging-service/

  2. zaantar
    Member
    Plugin Author

    Posted 1 year ago #

    Was there any warning or error of some kind?

  3. icc97
    Member
    Posted 1 year ago #

    I've got the same issue. I'm using WP 3.5.1.

    1. This is for the very first time trying to delete a log entry
    2. I go into Dashboard | System log
    3. Click in the check box of the first log entry (ID 1)
    4. From the 'Bulk actions' dropdown select 'Delete'
    5. This redirects me to the admin dashboard
    6. Going back to the System log still shows the log there
    7. Looking at the entries database table - the row ID 1 is still there

    Actually I've done further testing and on the second attempt (following the same process above), on delete the page redirects back to itself and the log entry was actually deleted.

    In my separate localhost environment it is consistently failing i.e. delete and 'mark as read' both redirect to the dashboard and don't alter the database. You can delete rows by clicking on the 'Remove all log entries from this category' link as well as 'Delete this log category' link. It is also WP 3.5.1 but is running on a IIS local host.

  4. icc97
    Member
    Posted 1 year ago #

    On trying to 'Mark as read', this is the URL that appears in the when on the dashboard screen (when there should have been a redirect back to the page):

    http://mydomain.com/wp-admin/index.php?_wpnonce=0901c4d1dc&_wp_http_referer=%2Fkleverlmr-lmrpartners.com%2Fhttpdocs%2Fwp-admin%2Findex.php%3Fpage%3Dwls-superadmin-overview&action=-1&paged=1&entry[]=7&action2=mark-seen

  5. icc97
    Member
    Posted 1 year ago #

    If the table is filtered on one of the categories then the delete's work fine.

    After realising that I added this line (copied from wls_superadmin_overview_page_view) to the admin-overview.php at line 103:

    <input type="hidden" name="page" value="wls-superadmin-overview" />

    Delete now works for me on localhost for both the filtered view and the main overall view.

  6. zaantar
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for your information. Please be patient now, this plugin's code is in quite bad shape and needs some major changes.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic