WordPress.org

Ready to get started?Download WordPress

Forums

Luminescence Lite
[resolved] Italics (8 posts)

  1. Raquel Sallaberry
    Member
    Posted 5 months ago #

    Hy,

    When I write my post and I mark italic it does not work on visual mode, neither after published. But if you see the text editor you can see the italics tags .

    Someone with the same problem here?

    My blog is janeausten.com.br

  2. StyledThemes
    Member
    Theme Author

    Posted 5 months ago #

    Hi Raquel...I'm just exploring this issue to see what is happening. I noticed that even the tags that wrap the italic words is being stripped out of the source code with this theme and totally perplexed by this.

    Anyway, I am looking into this now and will follow up shortly.

    Update: I just realized that the WordPress excerpt function strips all HTML formatting. Annoying actually, but I will find a solution to allow formatting and do an update.

  3. StyledThemes
    Member
    Theme Author

    Posted 5 months ago #

    Follow up. As mentioned, WordPress strips out all html formatting from excerpts...but there are a couple solutions:

    1. plugin for excerpts
    2. This theme has an option setting to choose content instead of excerpts. You can switch to that setting and your formatting will show.
  4. Raquel Sallaberry
    Member
    Posted 5 months ago #

    I thank you for your follow up!

    But I've turned my blog from "excerpts" to "content" and my italics remain no italics. I'll keep this format until monday just in case you can take a look.

    Perhaps some incompatibility with new 3.7.1 WP...

    I have loved the template but I need the italics, you know, my blog is about books and they have italics galore!

    raquel

  5. StyledThemes
    Member
    Theme Author

    Posted 5 months ago #

    A fix for you...which will be part of an update to the theme soon. In your theme's style.css file, look around line 428 for this:

    /* Typography
    -------------------------------------------------------------- */
    p {
    margin: 0 0 27px 0;
    }

    Right after the last curly bracket, add this:

    em {
    	font-style: italic;
    }

    Normally I would say don't modify the parent theme files but this one you can because it will be part of the next update. I also just tested this with the content (no excerpt option) and I saw my italics.

  6. Raquel Sallaberry
    Member
    Posted 5 months ago #

    Oh! Dear!

    my italics are back! Thank you! Now my blog will be back to excerpts, because I dont´need italics in the excerpts, only in full content!

    Thanks a lot and have a very nice Sunday!

    raquel

  7. StyledThemes
    Member
    Theme Author

    Posted 5 months ago #

    You're very welcome...wanted to make sure this worked for you :)

    Unless you have any other questions, is it safe to say this topic is resolved?

  8. Raquel Sallaberry
    Member
    Posted 5 months ago #

    Yes! It's lovely resolved!

    Thanks again, raquel

Reply

You must log in to post.

About this Theme

About this Topic

Tags