WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Italic Fonts Not Displaying on Front-end (3 posts)

  1. Ramandeep Singh
    Member
    Posted 2 years ago #

    Hi!

    I need help of theme developers. Our Site http://goo.gl/8iIZE has a little prob. with the used theme.

    We've modified the the theme's original font with custom CSS. And using 'Arial' font currently as body font. But after using custom CSS, the Bold and Regular Fonts are working, but Italic Font are not displaying on front-end of the website's pages i.e. The "..." part at http://goo.gl/ObqeH is originally Italic, but it is displaying as regular font at front-end of the site.

    How to fix this? Can anyone help us? Thanks in Advance.

  2. alchymyth
    The Sweeper & Moderator
    Posted 2 years ago #

    at the beginning of the main stylesheet (can't exactly tell what file this is, because your wt3c is interfering) is a reset-section:
    body, div, span, object, iframe, h1, h2, h3, h4, h5, h6, p, blockquote, pre, a, abbr, acronym, address, code, del, dfn, em, img, q, dl, dt, dd, ol, ul, li, fieldset, form, label, legend, table, caption, tbody, tfoot, thead, tr, th, td, article, aside, dialog, figure, footer, header, hgroup, nav, section {margin:0;padding:0;border:0;font-weight:inherit;font-style:inherit;font-size:100%;font-family:inherit;vertical-align:baseline;}

    remove the em, form that line;

    or add somewhere further down, add:

    em { font-style: italic; }

  3. Ramandeep Singh
    Member
    Posted 2 years ago #

    Thank You very much for help @alchymyth.
    It's resolved with em { font-style: italic; }

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags