WordPress.org

Ready to get started?Download WordPress

Forums

Opening Hours
[resolved] [closed] It is not working with wordpress 3.8.1 (11 posts)

  1. rpress1971
    Member
    Posted 4 months ago #

    Hello,

    When I finalize the installation the following message appears: "The plugin generated 2635 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin".

    And on top of the plugin page appears the following code: "'H:i', 'date-format' => 'd.m.Y' ); /* unset default if setting already set */ foreach ( $default_settings as $key => $value ) if ( op_get_setting( $key ) ) unset( $default_settings[ $key ] ); /* apply remaining settings */ $wp_opening_hours = new OpeningHours; $wp_opening_hours->applySettings( $default_settings ); } register_activation_hook( __FILE__, 'op_activate' ); ?>".

    Could you help me please!

    Thanks,

    https://wordpress.org/plugins/wp-opening-hours/

  2. antremo
    Member
    Posted 4 months ago #

    I have the same problem?, Do you have the answer?. Thanks

  3. calitel
    Member
    Posted 3 months ago #

    In my case, it installs but only shows the message "Closed". I have yet specified opening hours.

  4. janizde
    Member
    Plugin Author

    Posted 3 months ago #

    Hi you all,
    this problem is likely caused by the default-settings implementation which currently works via an activation hook. I will move this to the OpeningHours class, then it shouldn't be a problem anymore.
    I think that your php config causes this problem as it may not support the '<?' Opening Tags for php but only the '<?php'

  5. ExtraPaul
    Member
    Posted 2 months ago #

    Same problem with WordPress 3.9.

  6. Usayd
    Member
    Posted 2 months ago #

    This issue is still present in 3.9, it does work if you enable short_open_tag in php.ini but it would be better to do a global fix on the plugin itself.

  7. davilajoelr
    Member
    Posted 1 month ago #

    I am having the same issue as well.

    'H:i', 'date-format' => 'd.m.Y' ); /* unset default if setting already set */ foreach ( $default_settings as $key => $value ) if ( op_get_setting( $key ) ) unset( $default_settings[ $key ] ); /* apply remaining settings */ $wp_opening_hours = new OpeningHours; $wp_opening_hours->applySettings( $default_settings ); } register_activation_hook( __FILE__, 'op_activate' ); ?>

  8. Per the forum welcome if you need assistance please start your own topic.

    https://wordpress.org/support/plugin/wp-opening-hours#postform

  9. davilajoelr
    Member
    Posted 1 month ago #

    It is still the same topic with the same problem unless u are wanting the same problem spread across multiple topics

  10. janizde
    Member
    Plugin Author

    Posted 1 month ago #

    I'm currently working on 2.0 and I don't use the short opening tags anymore.

  11. valentinus
    Member
    Posted 3 weeks ago #

    Any word on the status of this? I'm presently using the plugin on WP version 3.9.1 and receive the same error as described above:

    'H:i', 'date-format' => 'd.m.Y' ); /* unset default if setting already set */ foreach ( $default_settings as $key => $value ) if ( op_get_setting( $key ) ) unset( $default_settings[ $key ] ); /* apply remaining settings */ $wp_opening_hours = new OpeningHours; $wp_opening_hours->applySettings( $default_settings ); } register_activation_hook( __FILE__, 'op_activate' ); ?>

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic