WordPress.org

Ready to get started?Download WordPress

Forums

Ultimate TinyMCE
[resolved] it doesn't show the selected items in the editor (9 posts)

  1. samuelr2010
    Member
    Posted 1 year ago #

    I have installed both versions of ultimate tinymce 4.2 and 4.0.9 and both show just a few icons in the editor. I selected to install the 'default icons' from the top button, and it suppose to installed many in the third and 4th row, but this is a screen-shot of what it shows in the new page editor:

    http://img843.imageshack.us/img843/1851/ultimatetinymce.png

    I have deactivated all the plugins I had to see if that fix the problem and after deactivating those plugins I reinstalled ultimate tinymce and still shows the same icons as in the screenshot.

    Any way to fix this problem ?
    thanks, appreciated any help.

    http://wordpress.org/extend/plugins/ultimate-tinymce/

  2. Marventus
    Member
    Plugin Author

    Posted 1 year ago #

    Hello, Samuel.
    Very sorry for the issue you are experiencing.
    By looking at the screenshot you shared, I can see buttons on row 1 that are not being added by UTMCE. Do you have any plugins or themes adding them to the editor? Because that might be what's causing the issue.
    To test this hypothesis, you would have to revert your theme to WP default's (TwentyTwelve in 3.5+ versions) and disable all your plugins, except for UTMCE.
    Once you try that, please post back again with your results.
    Thanks!

  3. samuelr2010
    Member
    Posted 1 year ago #

    you are right, I disabled all plugins except UTMCE and revert the theme to twewntyten and I got all the icons:

    http://img43.imageshack.us/img43/6555/ultimatetinymcewithtwen.png

    The question would be how do I start troubleshooting the theme I am using that is interfering with UTMCE ?

    the theme has a file called shortcodes.php :

    If I rename that file should this help ?

    Edit: I renamed the file: /themes/nameoftheme/lib/shortcodes/shortcode.php to something else and it disabled the whole WP site, so I'm newbie and that's not the answer. But I see that the folder ../lib/shortcodes contains the code, js, css and images that appear in Row 1 that were added by this theme so seems like it's going to be too dificult to fix it.

  4. Marventus
    Member
    Plugin Author

    Posted 1 year ago #

    Samuel, what theme are you using? Is it free or premium? If it's free, post a link so I can download it and see what's going on. If it's premium, I won't be able to help you due to licensing restrictions and WP general guidelines, so you should contact the authors' dedicated support system instead and ask them how they are going about adding their buttons to the editor.

  5. samuelr2010
    Member
    Posted 1 year ago #

    it's a free theme, it's called videozone and can be downloaded at fthemes.com ... you'll recognize it because the first loaded slide image is from Fringe the FOX tv series.

  6. Marventus
    Member
    Plugin Author

    Posted 1 year ago #

    Ok, I'll download it and take a look. This:

    NO sponsored links & Encrypted files

    combined with the fact the theme is not listed in the WP theme directory raises a major red flag in my head, though.

  7. Marventus
    Member
    Plugin Author

    Posted 1 year ago #

    Ok, it seems the issue is related to the way the theme is adding the buttons to the editor, more particularly, the mce_buttons and mce_plugins functions and how they are being called.
    The problem seems to be coming from VideoZone since it is keeping other plugins' buttons from initializing in the editor, such as Next Gen Gallery's, whereas UTMCE is working fine with other plugins and themes.
    Here are some screenshots:
    http://imagebin.org/252411
    http://imagebin.org/252413

    What I suggest you do is edit VideoZone's shortcode.php file manually, look for these lines (47 to 50):

    if ( get_user_option('rich_editing') == 'true' ) {
        add_filter( 'mce_external_plugins', array(&$this, 'mce_plugins') );
        add_filter( 'mce_buttons', array(&$this, 'mce_buttons') );
    }

    and escape them:

    /*
    if ( get_user_option('rich_editing') == 'true' ) {
        add_filter( 'mce_external_plugins', array(&$this, 'mce_plugins') );
        add_filter( 'mce_buttons', array(&$this, 'mce_buttons') );
    }
    */

    That should prevent the theme from adding its shortcode buttons. You can still access VideoZone's shortcodes by using our Shortcodes button in the editor.
    If you ever update the theme, you are gonna have to re-escape those lines.
    Cheers!

  8. samuelr2010
    Member
    Posted 1 year ago #

    Thanks very much appreciated, commenting that if statement has fixed the problem, I would have never had guessed that part as I was trying to rename the whole file itself (shortcode.php) and got the site disabled.

    I will set this as a resolved topic, again thanks for your help!
    Samuel R.

  9. Marventus
    Member
    Plugin Author

    Posted 1 year ago #

    Thank you for your patience and for letting us know of this problem.
    Good luck with your site!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.