WordPress.org

Ready to get started?Download WordPress

Forums

Ceceppa Multilingua
[resolved] It crashes :( (22 posts)

  1. Jakub
    Member
    Posted 1 year ago #

    Hello,

    I'd like to use your plugin but unfortunately my wordpress crashes. Here some examples:

    Whatever I do having the plugin installed WordPress crashes displaying this:

    Warning: in_array() [function.in-array]: Wrong datatype for second argument in /faces/wp-content/plugins/ceceppa-multilingua/ceceppaml.php on line 1015

    Id be grateful for any clue.

    Best regards,
    Kuba

    http://wordpress.org/extend/plugins/ceceppa-multilingua/

  2. Alessandro Senese
    Member
    Plugin Author

    Posted 1 year ago #

    Update to 1.0.8 and let me know if the problem is fixed :)

  3. manuelraigada
    Member
    Posted 1 year ago #

    I'm trying to install your plugin (1.0.8 version) on my site as well and the frontend also crashes. The backend is still functional.

    This is the the error I get:

    Warning: implode() [function.implode]: Invalid arguments passed in /home2/zsadeyad/public_html/wp-content/plugins/ceceppa-multilingua/ceceppaml.php on line 994

    Warning: implode() [function.implode]: Invalid arguments passed in /home2/zsadeyad/public_html/wp-content/plugins/ceceppa-multilingua/ceceppaml.php on line 994

    Warning: implode() [function.implode]: Invalid arguments passed in /home2/zsadeyad/public_html/wp-content/plugins/ceceppa-multilingua/ceceppaml.php on line 994

    Warning: Cannot modify header information - headers already sent by (output started at /home2/zsadeyad/public_html/wp-content/plugins/ceceppa-multilingua/ceceppaml.php:994) in /home2/zsadeyad/public_html/wp-includes/pluggable.php on line 876

    Any clue on what's happening? thanks a lot in advance!

  4. Jakub
    Member
    Posted 1 year ago #

    Thx mate. The message disappered but now nothing is loading. O get a blank page only with this title:

    <title>
    <b>Fatal error</b>: Maximum execution depth reached (1000) in <b>/faces/wp-includes/cache.php</b> on line <b>453</b>

    <b>Fatal error</b>: Maximum execution depth reached (1000) in <b>Unknown</b> on line <b>0</b>
    </title>

    Best regards,
    Kuba

  5. Alessandro Senese
    Member
    Plugin Author

    Posted 1 year ago #

    Fox "manuelraigada",
    I've fixed warning in 1.0.9

    For "lambrych".
    Have you installed other plugin? If yes, try to disable one by one and tell me its name...

  6. Jakub
    Member
    Posted 1 year ago #

    I switched off and removed all of the plugins. I lft only akismet and regenerate thumbnails but not active. Now when I only enter the website i see only this:

    Warning: implode() [function.implode]: Invalid arguments passed in /faces/wp-content/plugins/ceceppa-multilingua/ceceppaml.php on line 994

  7. Alessandro Senese
    Member
    Plugin Author

    Posted 1 year ago #

    I've fixed that warning in 1.0.9, Had you updated the plugin?

  8. Jakub
    Member
    Posted 1 year ago #

    Yes of course - I'm watching the version number and keep it updated. The message appears in 1.0.9 !

  9. Alessandro Senese
    Member
    Plugin Author

    Posted 1 year ago #

    Yes, I've commited wrong file to wp..

    Update to 1.0.10

  10. manuelraigada
    Member
    Posted 1 year ago #

    In my case, it seems like everything works great with this version.

    Thanks a lot for your time and effort! :)

  11. Alessandro Senese
    Member
    Plugin Author

    Posted 1 year ago #

    you are welcome

  12. Jakub
    Member
    Posted 1 year ago #

    Hello,

    I think it works on my fresh local installation, but not on my site where I was trying previous versions of the plugin. Before, I removed from the database by hand plugin related tables. Now, when I install the plugin 1.0.11 once again, the installation script doesn't recreate the tables and thus I cant add new languages via plugin settings. Moreover, as I dismissed the advice box it's not appearing neither anymore (even when I reinstall, delete the plugin etc. ). What an I do to make a fresh install of the plugin?

    Thank you for your effort.

    Kuba

  13. Alessandro Senese
    Member
    Plugin Author

    Posted 1 year ago #

    For recreate tables go to "yourdomain.com/wp-admin/options.php" find the option "cml_db_version" and set value to 0

  14. Jakub
    Member
    Posted 1 year ago #

    Thx a lot. I deleted all the options and tables and recereated but the box with "assign all the exisitng postos to default language" is not appearing. I think this option should appear somewhere in the plugin settings to get independet of choosing "hide" once - I mean bulk assign of the exisitng posts. What do you think?

    Thanks a lot one more time

  15. Alessandro Senese
    Member
    Plugin Author

    Posted 1 year ago #

    Set this option "cml_need_update_posts" to 1

  16. Jakub
    Member
    Posted 1 year ago #

    Good - thx - I managed to make it appear one more time. But, when i click on the link and execute : "blabla/wp-admin/edit.php?&cml_update_posts=1" I got this:

    Fatal error: Call to a member function get_default_lang_id() on a non-object in /faces/wp-content/plugins/ceceppa-multilingua/fix.php on line 93

    Thx again

  17. Alessandro Senese
    Member
    Plugin Author

    Posted 1 year ago #

    Ops, fixed in 1.0.12 :)

  18. Jakub
    Member
    Posted 1 year ago #

    Thx. I discovered today another bug. I'll show the flow control.

    I have a webiste with two languages (l1,l2).

    1. I create two posts in l1 and l2.
    2. I delete the l2 post (it goes to trash). Hwever, the l2 post is still linked to l1.
    3. I try to remove the l2 post from the trash and i get this:

    Warning: array_unique() [function.array-unique]: The argument should be an array in /faces/wp-content/plugins/ceceppa-multilingua/fix.php on line 174

    Best regards,
    Kuba

  19. Alessandro Senese
    Member
    Plugin Author

    Posted 1 year ago #

    it was not a bug, but one thing desired ...
    But you're right, it is easier if I cancel the connection when you trash a post or page :)

    The other problem its only a warning.
    In next update I've removed warning and connection between trashed posts...

  20. Jakub
    Member
    Posted 1 year ago #

    The problem is that it's not possible to remove the connection (imagine I want to relink the paga p1 with translation p2 to another translation p3 made by other editor). And if you try to remove a post there is a blank page with errors. I'd my editors to work independently - when they see en error like this they will be scared.

  21. Alessandro Senese
    Member
    Plugin Author

    Posted 1 year ago #

    I've fixed the problem. I am completing the last changes :)

  22. Alessandro Senese
    Member
    Plugin Author

    Posted 1 year ago #

    Fixed :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.