WordPress.org

Ready to get started?Download WordPress

Forums

Featured Video Plus
Issues with Pinboard Theme (6 posts)

  1. erm0613
    Member
    Posted 1 year ago #

    We're having issues with out theme. The video feature images work great until the site has to refresh, then they stop auto scaling.

    Here's our site:

    techheads.me

    Mind helping us out?

    http://wordpress.org/extend/plugins/featured-video-plus/

  2. Alexander Hoereth
    Member
    Plugin Author

    Posted 1 year ago #

    The plugin uses jQuery fitVids for auto sizing the videos to their parent container. But this is only done with videos existing on page load. So for every other video which is loaded using an AJAX request later in time you need to manually recall .fitVids

    Your theme (I guess) adds this JS to your blog's head: http://nopaste.info/1893f0574f.html
    Everything in function(entries){ is called when the site is finished loading new content. So there you have to add jQuery(".featured_video_plus").fitVids(); to start auto-resizing the newly added videos.

    I did not test this, but I reccon it will solve it just fine. All you have to do is find where the plugin actually produces this code ;)
    Hope this helps, Alex

  3. erm0613
    Member
    Posted 1 year ago #

    I added it, but it broke our infinite scroll and the content alignment. Any advice?

  4. Alexander Hoereth
    Member
    Plugin Author

    Posted 1 year ago #

    There is already

    $(".entry-attachment, .entry-content").fitVids({ customSelector: "iframe, object, embed"});

    in the callback. Maybe you can just change it to

    $(".entry-attachment, .entry-content, .featured_video_plus").fitVids({ customSelector: "iframe, object, embed"});

    Pinboard and my plugin both include fitvids. I am not sure if this alredy results in any conflicts on it's own..

  5. erm0613
    Member
    Posted 1 year ago #

    That did not do anything, it still disaligns the posts in the smaller boxes and breaks the infinite scroll.

  6. Alexander Hoereth
    Member
    Plugin Author

    Posted 1 year ago #

    The line occurs twice in the JavaScript: http://nopaste.info/410798b601.html
    Line 35 and 46.
    Try changing both occurences to this:

    $(".entry-attachment, .entry-content, .featured_video_plus").fitVids({customSelector: "iframe, object, embed, .video-js"});

    and change the featured video width on your Settings -> Media to something fixed.

    Just trial and error, sry :D

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.