WordPress.org

Ready to get started?Download WordPress

Forums

Issues with my Permalinks? (8 posts)

  1. bowstring_tv
    Member
    Posted 1 year ago #

    At least i think that is the issue. My site won't link to internal pages and the url change only gets longer the more i click onto different menu items.

    The Problem:

    I start on the home page:
    http://forefrontanalytics.com/Test/

    From there i click the menu item Firm:
    http://forefrontanalytics.com/Test/#!/firm
    Already in that url there is a #! that doesn't occur in my permalink id and i don't know what is going on. I actually have to delet the extra #!/ to get to my designated page that i wanted to get to. Then it will load BUT

    If i then navigate to another page the url keeps adding. Keeps the firm designation and adds the new one:
    http://forefrontanalytics.com/Test/firm/#!/fund-strategies

    It keeps the /Test/firm/ -- and then adds that weird #!/ again. can anyone help me fix this. If you wanted to peruse and see the error yourself designate here and try it yourself! http://forefrontanalytics.com/Test/firm/

    What I'm trying to accomplish:

    1. i would like smooth navigation between pages using %postname% permalinks
    2. i would like to be able to use column designations to split my pages --[one_third] etc. -- which i'm already using effectively-- to be able to create my own "sub page menus" and effectively link to other pages using the "link to other content" feature in the wordpress pages link feature.
    3. I'm also hoping to fix any other bugs so if you notice anything i'm open to all suggestions and modifications.

    Thanks for your help if possible.

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - esetting your custom permalinks back to the default setting via Settings -> Permalinks. If this works, then review Using_Permalinks before setting a custom permalink structure back up again.

  3. bowstring_tv
    Member
    Posted 1 year ago #

    Pug-ins were not the issue. Using these methods of eliination it seems to be a theme specific issue.

    I did try resetting the permalinks but that seems to create more problems.

    In which case i'm not sure how to proceed other than the uninstall, re install and start over? I would like to navigate all other options first. Are there any other suggestions?

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    What theme are you using? Where did you download it from?

  5. bowstring_tv
    Member
    Posted 1 year ago #

    I bought and downloaded it from themeforest. it is called:
    Beauty SPA - Ajaxified WordPress CMS Theme

    here is a link to it if you are curious: http://themeforest.net/item/beauty-spa-ajaxified-wordpress-cms-theme/2953387?sso?WT.ac=search_item&WT.seg_1=search_item&WT.z_author=kayapati

  6. bowstring_tv
    Member
    Posted 1 year ago #

    I'm also aware that now that I'm familiar with my clients information and site this should take half the time to do, which i don't mind doing. i guess like anyone, i was hoping for a quick fix i wasn't seeing...

  7. esmi
    Forum Moderator
    Posted 1 year ago #

    I'm sorry but as you are using a commercial theme, you need to seek further theme support from the theme's developer/vendor. We do not support commercial themes here.

  8. bowstring_tv
    Member
    Posted 1 year ago #

    That's ok, thank you so much for helping me to trouble shoot in the first place. I have contacted them and will wait. At least I learned a couple of tricks for my own personal use if I ever get stuck again.

    Thanks again!

Topic Closed

This topic has been closed to new replies.

About this Topic