WordPress.org

Ready to get started?Download WordPress

Forums

issues with MU subdirectory, as original blog isn't in '/' (11 posts)

  1. SyXbiT
    Member
    Posted 4 years ago #

    I have my main blog at mywebsite.com/blog (in folder /blog)
    I then wanted to add another, family. Since I have a subdirectory install, I created it like this /blog/family
    so I can successfully reach if I go to mywebsite.com/blog/family
    but I also have the domain name familywebsite.com, so I wanted to access it via familywebsite.com, and have it go to mywebsite.com/blog/family

    (fyi, I have godaddy domain and godaddy shared linux deluxe hosting)
    I tried going into hosting and pointing familywebsite.com to mywebsite.com/blog/family, but as that's technically not a directory it doesn't work.

    is this possible to do?
    I installed the wordpress MU domain mapping plugin, but when I load it I get the error

    The domain mapping plugin only works if the site is installed in /. This is a limitation of how virtual servers work and is very difficult to work around.

    every time I load the admin page, and the only way around it is to SSH into the server and manually delete the plugin

    could someone help me?

  2. It's because your install is in the /blogs/ folder and had that as part of the address.

    the message from the plugin is correct.

  3. SyXbiT
    Member
    Posted 4 years ago #

    right, I know. But is there a solution to doing what I want, or, because my initial blog is in /blog, is this impossible?

  4. Pretty much, yes.

  5. jpilantrose
    Member
    Posted 4 years ago #

    SyXbiT please post if you find a solution to this. I've run into the same issue with a blog that's been well established within its subdirectory. Should I rebuild the entire blog in the root and reroute it to its original subdirectory? Or am I generally out of luck on this?

  6. Should I rebuild the entire blog in the root and reroute it to its original subdirectory?

    You could move the blog to root and .htaccess redirect the old location to the new one. But ... yeah.

  7. jpilantrose
    Member
    Posted 4 years ago #

    Thanks. I guess this is the only way.

  8. pandikamal
    Member
    Posted 3 years ago #

    hi everyone,

    i had installed the MUWP in my local server and its working fine.
    i was found the domain mapping plugin and put it my plugin folder and then login to my wp admin, after it says the warning message as "
    The domain mapping plugin only works if the site is installed in /. This is a limitation of how virtual servers work and is very difficult to work around. "

    but i can't understand why its showing the error.
    please help me, how to use domain mapping plugin in my local server(localhost).

    regards,
    pandikamal

  9. It's becasue your main blog address is whatever.com/foldername/.

  10. yanngolf
    Member
    Posted 3 years ago #

    Hello,

    Jipilantose I have a same problem, can you explain me your solution with .htaccess ?

    Andrea_r "It's becasue your main blog address is whatever.com/foldername/."
    I do not know how else...

    Please help me...

    Can you help me by email ?I could send you the access.

    Thank you..

  11. If you read the entire thread, there isn't a fix involving htaccess.

Topic Closed

This topic has been closed to new replies.

About this Topic