WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Issues with installation - Blank screen (install.php) (31 posts)

  1. Anonymous
    Unregistered
    Posted 6 years ago #

    Hiya,

    Help! I followed the 5-minute guide up to the point of running install.php for the first time. However, whenever I try doing this I get a blank screen:

    http://www.farcry-theatre.org/wp-admin/install.php

    I posted this problem in a previous thread (please scroll down):

    @kylos101: thank you, I tried that but no effect whatsoever.
    @samboll: Yes, it's a different url because I'm a different user. I have the same problem as nickster4321 but that doesn't mean I am him/her. Hello? No reason to close the topic.

    Any ideas would be much appreciated :-)

  2. Anonymous
    Unregistered
    Posted 6 years ago #

    Anyone else with this problem - there are a few fixes at Colin McNulty's blog - namely, removal of the last blank line in wpconfig.php.

    Didn't work for me, sadly. Still blank screen of death, staring me in the face, server returns zero code.

    Anyone?

  3. outthere
    Member
    Posted 6 years ago #

    I don't have a clue. I know that a couple of weeks ago, maybe three, when I downloaded WordPress, I created a database.
    Four things, or three depending on your host.
    In config.php.
    1. localhost for some, or when you set up your database some hosts do it on another server. Make a note so you can enter. Or copy/paste.
    2. then: Usually your control panel login,name_wordpress
    3. Username. here again. cp name_whoopie .
    4. password. shouldaboughtahonda
    Don't use any of the above. (Or do.) Name the database whatever you want just point wordpress to it. It's all in the read me file.
    Assign the db user all priviledges. Whoopie gets to do it all.
    With some hosts, its a walk in the park. With others, well it ain't that bad. If they are worth a S---, call them. They'll help. If not, switch to Frontpages and tell your current host to kiss off.

  4. Anonymous
    Unregistered
    Posted 6 years ago #

    @outthere, thanks for your help.

    I edited config.php as described in the codex and triple-checked it, so I don't think it's that. I wonder whether the user I set up for the MySQL database has insufficient privileges. My provider uses phpMyAdmin 2.10.0.2, and I can't find the blinking link for setting of user privileges in there.

    Any other suggestions anyone? I hear this is one of the most common wordpress disasters, so somebody out there must know how to crack this one... ?

  5. Anonymous
    Unregistered
    Posted 6 years ago #

    forget about the last post - just read this - so no, that can't be it either.

  6. Samuel B
    moderator
    Posted 6 years ago #

    @samboll: Yes, it's a different url because I'm a different user. I have the same problem as nickster4321 but that doesn't mean I am him/her. Hello? No reason to close the topic.

    I didn't close the topic.
    I have noticed in the past that php memory being too low can cause this behavior.

  7. Croga
    Member
    Posted 6 years ago #

    Same problem here....

    Funny thing is: I have 2 websites running on this server. Installing WordPress on the first website was easy and that one works like a charm. Installing on the second website, using the same procedure, results in blank screen. Both wordpress instances have their own MySQL database with their own MySQL user.

    I've tried removing the last blank line in the config file to no effect. I have a hard time believing it would be anything to do with too little PHP memory as the first installation should then have had the same issues.

  8. Anonymous
    Unregistered
    Posted 6 years ago #

    @ samboll: if it does have anything to do with php memory - how do I allocate more? Is this a setting in php.ini?
    (Sorry, don't know an awful lot about php)

  9. Samuel B
    moderator
    Posted 6 years ago #

    If you have a php.ini you can do it there.
    You will see a line in the file to allocate memory. The default is usually 4MB- You can safely change this to 16MB or 20MB.

  10. Anonymous
    Unregistered
    Posted 6 years ago #

    Just discovered I don't have write access to it, so I'll ask my provider tomorrow to sort this out. Thank you.

    What if it isn't php memory, as Croga's post suggests?

  11. Anonymous
    Unregistered
    Posted 6 years ago #

    Samboll,

    You hit the nail on the head! Just discovered that I have write access to my php.ini via my ISP's admin panel. I increased memory_limit to 20MB - and it's working now. Thanks a lot dude!

    Croga and everyone else with this problem - hope this will work for you, too.

  12. Anonymous
    Unregistered
    Posted 6 years ago #

    A last PS, for everyone else encountering this problem - try

    • activating php error display on your server, or ask your ISP to do it for you
      if the problem has nothing to do with the memory size, this will at least give you the name and path of the file that causes the blank screen
      check file permissions on your server - I just had a blank screen again, and this time it was down to compat.php having dodgy permissions
  • Croga
    Member
    Posted 6 years ago #

    Checked php.ini. php has 100M available so I'm guessing that's not the problem.
    Checked file permissions; they're all set correctly.

    How do I activate php error display? That way I can give you guys a better idea of what's going wrong.

  • Anonymous
    Unregistered
    Posted 6 years ago #

    I'm not sure - my ISP did it for me (I rang them)

  • ljmac
    Member
    Posted 6 years ago #

    As this thread is marked "resolved", I've started another one with my own experience of this issue. I actually have the relevent PHP error:

    PHP Parse error: syntax error, unexpected T_ENCAPSED_AND_WHITESPACE, expecting T_STRING or T_VARIABLE or T_NUM_STRING in [URL removed for security reasons]/wp-admin/includes/media.php on line 154

    Now surely somebody must be able to figure out what's going on here? Clearly I'm not the only person experiencing this issue, so this looks likes a major bug to me.

  • ljmac
    Member
    Posted 6 years ago #

    Well, I've been messing around with 2.5, 2.5.1 and the just released 2.6, and no matter what I do, when I try to install any of them, I get the same blank screen and the same PHP error from /wp-admin/includes/media.php.

    However, I noticed 2.3.3 and earlier didn't have this file, so I decided to try installing it. Voila! It works!

    So I was obviously installing it correctly, but there is clearly a serious bug in the code of /wp-admin/includes/media.php (from WordPress 2.5 upwards).

    As this file relates to the new admin interface, it explains why some people are getting blank admin screens after upgrading to 2.5 and later, while other people (like me) simply can't install it in the first place.

    I am going to need some very serious convincing that this bug has been fixed before I even consider "upgrading" to a newer WordPress version.

  • Anonymous
    Unregistered
    Posted 6 years ago #

    ljmac, sorry I might have marked this as "resolved" a little bit prematurely.

    I am running 2.5.1 and it works fine for me now. Did you check line 154 in media.php? Also, I know it says "syntax error" but did you check file permissions for media.php?

  • Glamdering
    Member
    Posted 5 years ago #

    Where can you find: php.ini

    Not seeing it anywhere on my server.

    I've tried the other fixes suggested without any luck.

    My issues: Blank screen for everything but wp-admin. When I login wp-admin does do a password check and will either tell me it's incorrect or correct, but instead of logging in on correct submission it just sits on wp-admin.

    Domain is http://www.citadel-of-light.com

  • Anonymous
    Unregistered
    Posted 5 years ago #

    I also had this problem as meny of you guys. I simply renamed the "/wp-content/plugin"-folder to something else, then it was ay okey to login to admin. After that I had to remove all unwanted plugins. (In my case "noflashupload")

  • Glamdering
    Member
    Posted 5 years ago #

    No luck there on that one for me.

  • Anonymous
    Unregistered
    Posted 5 years ago #

    Glamdering and Gymgrossisten (by the way - where do you guys get your login-names from?!) I think you're talking about a different problem.

    Basically, any php parsing or syntax error will result in a blank screen. This can happen while installing, or further down the road. If you can access wp-admin or the plugins folder that seems to suggest that your installations have already been completed (otherwise you'd be redirected to wp-admin/install.php).

    I recommend with any bsod to activate php error display. You probably won't be able to do this yourself, so ask your ISP. This will then output the particular issue you're encountering (it could be any number of things) to the screen, and you'll be able to deal with it.

  • Anonymous
    Unregistered
    Posted 5 years ago #

  • Glamdering
    Member
    Posted 5 years ago #

    Stone, Hunter - thanks for the help. I tried another upload with auto overwrite and used a fresh 2.6 download (is it possible that the first pack that went live last night had an issue?). Then also deleted gallery legacy elements in my wp-content folder. Also 2 other files in the folder db.php and wp-cache-config.php which were in the wp-content folder.

    My uneducated guess is that either a file i'd missed got re-uploaded/updated or the wp-cache stuff was conflicting with the 2.5/2.6 caching process.

    After that the site is working again.

    Thanks for your help.

    *huge sigh of relief*

  • saschaeh
    Member
    Posted 5 years ago #

  • technohead01
    Member
    Posted 5 years ago #

    ive reinstalled word press today and its worked, just how ive been tring it for the last loads of attempts, perhaps theyve fixed it??

  • saschaeh
    Member
    Posted 5 years ago #

    technohead01 - and you didnt change anything?

  • smoosh
    Member
    Posted 5 years ago #

    So my problem with installing WordPress (2.5.1 and 2.6.1) was a blank screen at the point where the install was running in /wp-admin/install.php.

    I was able to create the config.php using the web interface, however at the next step of actually installing WordPress it failed with no output to the screen and no error message in the server logs. It did not even get to the point of creating the database tables in the MySQL database.

    I found nothing that worked online about this despite many suggestions, but I happened on a fix pretty much accidentally.

    The fix was to add the following line to the .htaccess file in the root directory of the server.

    php_value zend.ze1_compatibility_mode "0"

    Do I know why it worked? No.

    It was a setting I had to change for another application (MediaWiki), and it had the added benefit of fixing me up (Though it still took a little bit of time to realize that was indeed the fix)

    Just throwing this out there for those that may be encountering the same thing. Hope it helps even one... Cheers.

  • ljmac
    Member
    Posted 5 years ago #

    I believe I have the solution to this issue. Unlike other php aps I've used, WordPress 2.5.x upwards seems to require UNIX carriage returns. Hence, if you edit a file on your PC or your Mac, it will have a Mac or PC style carriage return in the file, and this will completely break it.

    The only way I've found to solve this issue is to use a text editor (like TexEdit Plus on the Mac) which allows you to convert all the carriage returns back to UNIX carriage returns when you've finished editing.

    Note that when I first encountered this issue, I could not install WordPress 2.5.x upwards at all. However, since I figured this out, I've been able to run my blog for 2 months now without a single blank screen.

  • cnmoody
    Member
    Posted 5 years ago #

    i just found out what was causing this for me.

    the newest wp-config has the keys where you can input information inside the quotation marks.

    i made the dumb mistake of using two punctuation symbols (an ! and you're) and that was killing the install (or reinstall) for that matter.

    it may be something very obvious to most, but i screwed it up and haven't read that documented. hopefully that can help someone because it interpreted it as code and threw everything off.

  • etype76
    Member
    Posted 5 years ago #

    I had the same problem (blank screen) and it turned out that /wp-includes/script-loader.php hadn't completely uploaded

    PHP Warning: Unexpected character in input: ''' (ASCII=39) state=1

  • 12

    Topic Closed

    This topic has been closed to new replies.

    About this Topic

    Tags