WordPress.org

Ready to get started?Download WordPress

Forums

Issues with Godaddy dedicated server and WP (5 posts)

  1. tivers73
    Member
    Posted 3 years ago #

    I installed wordpress on my dedicated Godaddy server - Linux Cent OS with Plesk control panel). Here's my problem... when I try to upload files or plugins using the Wp dashboard I get error message -

    “active_cruises.gif” has failed to upload due to an error Unable to create directory /var/www/vhosts/airportshuttlefinder.com/httpdocs/wp-content/uploads/2010/12. Is its parent directory writable by the server?

    My wp-content directory is set to 755 but I had to create an "uploads" directory (set to 755) and "2010" directory (set to 777). Is setting the "2010" directory to 777 going to create a security hole? Can anyone suggest a safe work around. Godaddy is very strict about security and will shut down my server if there are any potential risks.

    Thank you in advance for your help.

  2. Pothi
    Member
    Posted 3 years ago #

    For your first question: Yes, it is a security hole. It doesn't matter which directory you set to 777.

    For your other question (Can anyone suggest a safe work around): I'm sorry, there is no safe work around that I know of. You should probably consult with GoDaddy on how to set up permissions for WP properly on their servers.

  3. tivers73
    Member
    Posted 3 years ago #

    I have spent hours calling the half-trained monkeys they call Godaddy support, and chatting online with support and it was pointless. They have no clue about WP or setting file permissions. I was hoping someone in this forum could help. I'm willing to pay if necessary... I just need someone who knows what they're talking about. Does anyone have WP installed on a Godaddy dedicated server? How do you set your permissions?

  4. arkgroup
    Member
    Posted 3 years ago #

    tivers73,

    First thing I want to say: godaddy will not suspend your account because of any issues, because it's dedicated server. Permission issue is not a problem at all. Even 777 is safe if you know how to use it.

    Permissions like 777 allows other system users to have all access to that folder or file. It doesn't mean that anybody in the world may have access to it, but anybody in the file system.

    To fix the problem you need to set 777 permissions for /uploads/ folder. If you want to make it extra secure, you may set open_basedir php parameter in php.ini (or vhost.conf) to make it a little bit more secure. It will prevent potential attackers to screw with the whole server, but will not prevent spoiling your website anyway, so I just recommend you to create backups once a week. You may simply set cron to do backups.

    To make php safer, you may try to recompile php to cgi mode with suphp, but from my experience it probably wont work with plesk, so I don't recommend to do this.

  5. Inextricable
    Member
    Posted 2 years ago #

    @tivers73:

    did you solve this yet? I have a dedicated on Godaddy with plesk as well and I have another dedicated with simple control panel (older) that DOES work with other WP installs I have there... It's the theme and all it's sub folders are set to 755 and the files are set to 644.

    If anyone knows whats up with this I'd like it if you could please share the knowledge, Cheers. Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.