WordPress.org

Ready to get started?Download WordPress

Forums

issues with beta2 (7 posts)

  1. Anointed
    Member
    Posted 4 years ago #

    first of all, is there a forum for reporting issues with 3.0 beta2?

    If this is the place here, then the main issue I am finding is during install it said I do not have mod_rewrite activated, which I know for a fact is not the case. This server has it, I checked php info file, and sure enough it's on.

    The problem is now because wp thinks I do not have it activated, I am ending up with an index.php in my permalinks which I do NOT want and cannot find the place to override it.

    I can also report, than when multisites are turned on they work perfectly for me so far.

    However combining it with buddypress 1.3 trunk, really screws things up. Probably due to the mod_rewrite issue above.

    anyhow....
    How do I override the mod_rewrite issue so that I can have my permalinks proper?

  2. Even without mod rewrite, the default shouldn't include index.php. The default is http://example.com/?p=N so there's probably something configured strangely on your server.

    Have you ever tried to install any version of WP before on this server? Did you check with your host about mod_rewrite, or wordpress in specific? Are you on a Unix server or an IIS box?

  3. Anointed
    Member
    Posted 4 years ago #

    Yes this server runs a number of wp 2.9.2 wpmu sites with no issues. I checked my php info file and sure enough mod_rewrite is turned on. I am on Unix, Linux redhat, php 5.2.6, mysql 5 series.

    I tried installing a new copy of beta2, but had the same problem yet again.

    I'm curious, there has to be a way to override this stupid wp behavior. Is it as simple as editing something in the db or the htaccess file?

  4. Anointed
    Member
    Posted 4 years ago #

    I have completely removed all the files and the database table itself multiple times now. Every single time I install the beta2 it seems to work, yet if I go to the permalinks settings page, it shows me index.php in all cases.

    How in the world do I remove this?

    The first time I installed the beta it said something about apache missing mod_rewrite, but I have yet to see this error again. It simply goes through the install with no issues, yet I still have this problem.

    very frustrating...

  5. Are you running all your WPMU sites as the same account on the server and the same domain or different ones? It's possible that mod_rewrite is, somehow, turned off on that one account, but honestly, that's the only time I've ever seen that problem.

    What happens if you try to install a new 2.9.2 MU install as the same account/domain on that server?

  6. Anointed
    Member
    Posted 4 years ago #

    I installed 2.9.2 on this same domain last night as a test, and it worked as expected. The site actually is just a testbed, and had 2.9.2 on there prior to me doing 3.0.

    I believe this is already reported:
    http://core.trac.wordpress.org/ticket/12255

    It seems to me that something changed in the network settings for 3.0 as they try to make it more compatible with other systems. In this case, it's really screwing with me.

    If there were just a way to tell wp, than I have apache as a default that would help a lot. Kind of force it to recognize my mod_rewrite and not rely upon other functions

    My problem is I can't even begin to work with 3.0 trying to prepare for upgrading all the clients if I start out with bad permalinks.

    Oh, and I was wrong on the warning. It only shows up when I activate the network itself. However I still have the permalink issue even before activating multisites.

  7. Update that trac ticket (and reopen it) with this info, then. Best way to get the word out :)

Topic Closed

This topic has been closed to new replies.

About this Topic