WordPress.org

Ready to get started?Download WordPress

Forums

Edge Suite
[resolved] Issues using the plugin with a custom post type (7 posts)

  1. madumatt
    Member
    Posted 1 year ago #

    Hi!
    I'm using this awesome theme called Blox from themezilla.com, and i'd like to include an Edge animation in some portfolio custom post, (the media part on beside the content part) the support from themezilla doesn't give any support on 3rd party plug-ins, anyhow they advised me to use a shortcode in the video embed box, but that one doesn't work though... :(
    any idea ?

    many thanks in advance
    cheers

    http://wordpress.org/extend/plugins/edge-suite/

  2. ti2m
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,
    I just tested the default custom post type from http://codex.wordpress.org/Post_Types and the shortcodes work for me.

    Now we are a bit stuck, as they don't want to/can't assist you and I can't get the theme to test it... (that's one of the reason why I don't like proprietary themes).

    Do the animate shortcodes work in a "normal" post? Or does that post type not exist anymore?

  3. madumatt
    Member
    Posted 1 year ago #

    Well it works in the custom “normal” post if I use the shortcode in the normal content field, like a normal usage of that... but there are some custom fields in the this custom post where to upload media, image or a sound or embed a video for the post, and this is the place where i want to have my animation since these media will be css tagged with the right tags

  4. ti2m
    Member
    Plugin Author

    Posted 1 year ago #

    Do other shortcodes work in these custom fields? I'll add the edge animate shortcode the way you would add any other shortcode (at least I think so), so I'm not sure what I can do to support custom fields in a custom post type that the plugin doesn't know anything about. My guess would be that shortcodes have to be enabled in general for this field. But if other shortcodes work in the field then I can check again an see what can be done.

  5. madumatt
    Member
    Posted 1 year ago #

    nope any other shortcodes don't work in the custom fields... (at least in the only one provided to me which is a video embed field) It literally writes back the shordcode himself...
    I've just asked the themezilla support if there is any way to add a custom field taged with the “entry-media” class so that I can embed any html & shordcode stuff in the media place.
    Waiting for the answer :)
    thanks for your support

  6. madumatt
    Member
    Posted 1 year ago #

    It works ! got support from themezilla forum, and the solution was effectively enabling shortcuts in the concerned custom fiels, by editing a line in the template-portfolio.php.
    here's the link to the thread, (for verified customers only) in any case:
    http://www.themezilla.com/support/discussion/4641/integrate-an-adobe-edge-animation-using-edge-suite-plug-in#Item_1

  7. ti2m
    Member
    Plugin Author

    Posted 1 year ago #

    Great to hear. Same applies for widgets, that's why I had to add an option in the settings to enable shortcode replacement in widgets. Thanks for the link, might help others.

    Thanks for using Edge Suite, marking this as resolved.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic