WordPress.org

Ready to get started?Download WordPress

Forums

Issues uploading themes via WP admin area (4 posts)

  1. avil4723
    Member
    Posted 2 years ago #

    Hi guys,

    I have a problem with uploading themes through WP's admin area.

    First, I got this error:

    "Is its parent directory writable by the server?"

    After trying several of the solutions suggested in other posts (CHMOD 777 of 'wp-content' & 'uploads' folder; creating the 'uploads' folder manually in confixx, etc.). In the end I solved it by unticking "Organize my uploads into month- and year-based folders" (in Settings > Media) fixed this issue.

    Then however I got a new error (after entering my FTP credentials):

    "Downloading install package from '/var/www/user/html/mydomain/wp-content/uploads/genesis.1.7.1.zip…'
    Download failed. A valid URL was not provided."

    How do I fix this?

    Some background info: This is a fresh WP install. An Akismet update this morning installed without problems. Swapping to 'pretty links' needed me to create a .htaccess file first before being successful.

    Warning: potential overkill information!
    After surfing around subfolder installs seem to be more complicated thus I should explain my situation a bit more in case the error lies deeper. I have three domains linked to my webspace 111.com, 222.com, 333.com. In confixx I've allocated each domain a specific subfolder as new "root" (eg. '/html/111'). I've done this so that each domain has its own independent website and you will not see 'www.xyz.com/111/...', but instead 'www.111.com/wp-content/' (which is in fact '/html/111/wp-content'). I hope my description does not confuse anyone. As yoiu might be able to tell I'm a noob with WP and trying hard to get it up and running for my new blog.

    Any help is much appreciated.

    Cheers,
    Antonio

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    Remove your manually created uploads folder. It is essential that WordPress creates this folder. Try changing the permissions on the wp-content directory to 766. If you still have problems, try 767, 775 or 777. Once your uploads are working, change the permissions on wp-content back to 755 again and check that everything still works OK.

  3. avil4723
    Member
    Posted 2 years ago #

    Hi Esmi,

    Just uploaded a custom background by setting wp-content to 767 and it worked! However, i noticed that uploads was also set to 767. I returned both to 755.

    Thanks for your reply and help.

    Would there be any way to fix this issue permanently without creating a security issue (ie. 767)? I'd really like to set WP up in a way that it won't cause any problems in future.

  4. moheetarora
    Member
    Posted 1 year ago #

    hi I am trying to upload theme but this message is displaying

    Installing Theme from uploaded file: small-business-pro.zip
    Downloading install package from /home/globalbi/public_html/wp-content/uploads/small-business-pro.zip…

    Download failed. A valid URL was not provided.

    Please help :(

Topic Closed

This topic has been closed to new replies.

About this Topic