WordPress.org

Ready to get started?Download WordPress

Forums

GRA4 Social Network
[resolved] Issues upload Avatar (13 posts)

  1. rpatwall1206
    Member
    Posted 1 year ago #

    I tried to upload an Avatar and received an error message that said "411 length required" What does that mean? I am also umable to set the avatar for wp post using the 'Feature Image Function". I am using the Custom Community theme and Thought you might have some ideas that may lead me to a solution.

    Thanks

    http://wordpress.org/extend/plugins/gra4-social-network/

  2. trof
    Member
    Plugin Author

    Posted 1 year ago #

    You are uploading picture at something like
    itsdivinity.com/gra4/avatar/edit/GRA4_someLongNumber_someShortNumber , right?
    Could you please try to upload different picture. Does it produce the same "411 length required" error ?

  3. rpatwall1206
    Member
    Posted 1 year ago #

    Yes, first image was 237 X 215 so I tried a 150 x 150 still got error

    Thanks

  4. trof
    Member
    Plugin Author

    Posted 1 year ago #

    Awww =(
    Another thing that could of interrupt the process... Is your page password-protected ? If "yes" - could you please remove the protection and try again ?
    Thank you

  5. rpatwall1206
    Member
    Posted 1 year ago #

    This is a copy/paste of what the url looks like when I am about to upload avatar
    http://itsdivinity.com/gra4/avatar/edit/GRA4_534929_1

    This is what it looks like after I attept to upload the image I chose
    http://itsdivinity.com/gra4/action/avatar/upload

    The error says: "411 length required" and under that there is: nginx/0.7.67

    Thanks

  6. rpatwall1206
    Member
    Posted 1 year ago #

    No password protection.

  7. trof
    Member
    Plugin Author

    Posted 1 year ago #

    Ok. Thank you again for the error report. Looks like it requires deeper investigation. I'll get back to you as soon as we have results.

  8. trof
    Member
    Plugin Author

    Posted 1 year ago #

    Dear rpatwall1206,
    two questions:
    1. Please confirm you can upload pictures to WordPress (not to GRA4, to WordPress in-general) via web interface.
    2. What is the URL of your hosting provider ?
    Thank you

  9. rpatwall1206
    Member
    Posted 1 year ago #

    Yes, I am able to upload images to the media library.

    URL to host: Arvixe.com

    Thank you

  10. rpatwall1206
    Member
    Posted 1 year ago #

    I'm sorry the site hosting for (itsdivinity), url is:
    http://webhostingworld.net/index.php

  11. trof
    Member
    Plugin Author

    Posted 1 year ago #

    I see you have the avatar now... Did you tune-up the nginx?

  12. rpatwall1206
    Member
    Posted 1 year ago #

    I actually contacted my hosting to see if they could help, and it worked. However on my admin profile page it comes and goes. May I ask how you know that? My site requires user login and I currently have a maintenance sign up.

    Thank you

  13. trof
    Member
    Plugin Author

    Posted 1 year ago #

    Well, we encountered a bit similar problem before, although it's rare problem...
    Ok, the situation is... (you probably already know the details - it's for the guys who may read it later)
    The hosting has the Nginx/Apache pair, where the Nginx kinda sits in front of the Apache. Nginx is blazing fast for the static content, so if request goes for a picture, or CSS file, or something like that, the Nginx spits it right back. If it's complicated request, requires, say, to run PHP script, Nginx passes it to smart but slower Apache. Such a configuration is used on the systems to withstand really heavy load.
    The GRA4 software uses HTTP 1.0. Majority of web servers use 1.1 (we keep 1.0 to maintain compatibility even with older systems, presuming the modern systems must understand 1.0 as well ).
    The 1.1 and 1.0 have some differences, but the one we are interested in right now: when 1.0 transmits data, it sends a HTTP header with the data length in it. The 1.1 uses "chunked" protocol. The data literally is sent by chunks prefixed with chunk length.
    For some reasons Nginx has some setting, telling it to use HTTP 1.1 even when the client insists on 1.0, so for Nginx data looks corrupted.
    I was about to tell you the bad news that the situation in unresolvable until we implement HTTP 1.1 (we have such a plans for later) but you have really-really skilled guys on the techsupport of your hosting. Congratulations ! =)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.