WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Issues posting to my WP blog using Ecto and MarsEdit (5 posts)

  1. Edie Howe
    Member
    Posted 6 years ago #

    I'm having some weird issues ever since upgrading to WP2.5. I get failure messages when I try to post to my blog (http://littleredtent.net/LRTblog) using either Ecto or MarsEdit on my Mac 10.4 machine.

    Error message from MarsEdit:
    Post to Weblog Error
    Can't do post for (blog name) because the server reported an error. XML-RPC Response Parsing Failed: The XML parser could not parse the data.

    Error message from Ecto:
    Parsing Failure!
    Could not parse response for "metaWeblog.newPost". Please check the console log for more information.
    Console Log has this to say:
    Response:

    <br />
    <b>Fatal error</b>:  Call to undefined function: printr() in <b>/homepages/37/d224858424/htdocs/LRTblog/xmlrpc.php</b> on line <b>1080</b><br />

    This happens when I try either plain text or use any html tags.

    I am able to post from the admin console online just fine.

    A search here using "Parsing error call to undefined function" revealed nothing applicable.

    Thanks!

  2. 1MacGeek
    Member
    Posted 6 years ago #

    I started getting this as well, with Ecto.

    The last time it happened, it was the WordPress.Net.In problem. I have been going over my wordpress files, but I can't find anything like what happened the last time. The puzzling thing is I downloaded a new copy of WordPress 2.5 and put the new files in place that were suspect last time, and I am still getting a parse error.

  3. 1MacGeek
    Member
    Posted 6 years ago #

    UPDATE : I finally did find a discrepancy between my XMLRPC.PHP file and a brand new one downloaded from WordPress.

    The WordPress Copy, Line 10 :
    $HTTP_RAW_POST_DATA = trim($HTTP_RAW_POST_DATA);

    My copy, Line 10 :
    $HTTP_RAW_POST_DATA = mysql_escape_string(trim($HTTP_RAW_POST_DATA));

    And guess what? I replaced my XMLRPC.PHP with the fresh copy, and no more parse errors in Ecto, at least for me. Your mileage may vary, but I would appreciate hearing if it worked for anyone else.

  4. tstahmer
    Member
    Posted 6 years ago #

    Same problem, same solution

  5. Edie Howe
    Member
    Posted 6 years ago #

    Replaced XMLRPC.PHP with the version found in 2.5.1 (deleted the old one on my webspace via ftp first) with success. Looks like we have resolution, Houston. Much thanks, MacGeek.

    Edie

Topic Closed

This topic has been closed to new replies.

About this Topic