WordPress.org

Ready to get started?Download WordPress

Forums

qTranslate
Issue with wp-pagenavi plugin (2 posts)

  1. whoaloic
    Member
    Posted 1 year ago #

    Hi! I have problem with pagination through wp-pagenavi!
    When I open pages with paginated contents, it all works in the selected language (passing from a sub-page to another) until I try to get back to the first page of the content: in that case, the page is opened in the default language. In fact, I noticed that the /en/ (or /fr/, or /es/) part of the url disappears, so the page resets in the default language. But that only happens for the first page of the paginated content!
    Please check http://lesherbesfolles.eu/category/spectacles and navigate with pagination to understand my problem.
    Does anyone have an idea of what the problem is and of a possible solution? Thank you very much!

    http://wordpress.org/extend/plugins/qtranslate/

  2. emgerold
    Member
    Posted 1 year ago #

    Hi everbody,

    i've got exactly the same problem.
    Would be great if some one could help us...

    A Solution would be: Displaying the link ti the first page without page information. For example:
    http://www.example.com/en/
    instead of
    http://www.example.com/en/page/1/

    But I don't know how to do that.

    Thanks for any help!

    PS: A Quickfix with Javascript:
    jQuery('div.wp-pagenavi > a.page-numbers[href="http://blog.yoururl.com/en/page/1/"]').attr('href', 'http://blog.yoururl.com/en/');

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic