WordPress.org

Ready to get started?Download WordPress

Forums

WP Smush.it
[resolved] Issue with Smushing already upload images (8 posts)

  1. FilmBuffRich
    Member
    Posted 7 months ago #

    Just started working with SmushIt. It seems to be fine when uploading new image files, but I encounter a problem when I go into the Media Library and hit the Smush It button for already uploaded images, I get thrown to the front page of my site and when I go back to the Media Library, the photo isn't smushed. Thoughts?

    http://wordpress.org/plugins/wp-smushit/

  2. Hi there @FilmBuffRich,

    Hope your well today and thanks for your question.

    Are you trying to bulk smush already uploaded images, or just one at a time? It throws you to domain.com, when your trying to smush? Can I have a screenshot or a screencast would be great :)

    Thanks!

    Kind Regards
    Jack.

  3. FilmBuffRich
    Member
    Posted 7 months ago #

    Hi Jack,

    Sorry for the delay, hope you had a great Thanksgiving.

    I am trying to smush images one at a time in the Media Library (http://www.filmbuffonline.com/FBOLNewsreel/wordpress/wp-admin/upload.php) when it throws to throws to the main site page - http://www.filmbuffonline.com/FBOLNewsreel/wordpress/

    (The main site page is actually a redirect from just http://www.filmbuffonline.com. Would that have anything to do with this?)

    Rich

  4. WPMUDEV
    WPMU DEV Support Staff
    Plugin Author

    Posted 7 months ago #

    @FilmBuffRich,

    One way to find out. Please go to Settings > Media. Find the Smush.it related section. There you will see the drop down to control the Smush.it plugin. Turn off the auto process on upload. Save the settings.

    Now when you attempt to upload images do you still get redirected?

  5. FilmBuffRich
    Member
    Posted 7 months ago #

    The problem is not with new images being uploaded, it is with older images that have already been uploaded.

    I just checked my site's email address and discovered that I have gotten this notification from WP Firewall -

    WordPress Firewall has detected and blocked a potential attack!
    Web Page: http://www.filmbuffon line.com/FBOLNewsreel/wordpress/wp-admin/admin.php?action=wp_smushit_manual&attachment_ID=31313

    Warning: URL may contain dangerous content!

    Offending IP: [My home IP]

    Offending Parameter: action = wp_smushit_manual

    This may be a "WordPress-Specific SQL Injection Attack."

  6. FilmBuffRich
    Member
    Posted 7 months ago #

    OK, I just turned off WP Firewall and it looks like Smush it worked just fine. Seems like the two don't want to play together.

  7. WPMUDEV
    WPMU DEV Support Staff
    Plugin Author

    Posted 7 months ago #

    @FilmBuffRich,

    You will need maybe to go check the forums for that firewall plugins and ask them why they are flagging the URL as a potential issue? There is nothing wrong with that URL that I can see. There are dozens of 'security' plugins out there that seem to provide too many false positives than anything else.

    So let me break down the URL:

    http://www.filmbuffon line.com/FBOLNewsreel/wordpress/wp-admin/admin.php - Assumed this is the URL for your admin Dashboard.

    action=wp_smushit_manual = Parameter added because you chose to do a manual smash.it.

    attachment_ID=31313 = This is the ID of the image post your chose to process.

    So again I'm confused why it is flagging the URL as SQL injection.

  8. WPMUDEV
    WPMU DEV Support Staff
    Plugin Author

    Posted 6 months ago #

    Hey there.

    We haven't heard from you in awhile, so I just wanted to check in to make sure all was good.

    This thread was marked resolved, but please, if you still need help then just respond and open it back up. We can then take it from there. :)

    Hope you have a fantastic day!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.