WordPress.org

Ready to get started?Download WordPress

Forums

Admin Menu Editor
[resolved] Issue with notification bubbles on post type menus (5 posts)

  1. Hassan
    Member
    Posted 8 months ago #

    You know those little rounded bubbles that appear in the Plugins and Comments menu items when there are updates and unapproved comments? I also make use of them for menu items of custom post types to show the number of pending posts. I do this with the help of the Admin Tweaks plugin.

    The issue is that with AME active, those bubbles do no show up. It's like AME is overwriting the menu items and discarding any "updates" to appear over the menu items.

    I need to know why AME is doing this and whether there is a workaround.

    Thanks

    http://wordpress.org/plugins/admin-menu-editor/

  2. Janis Elsts
    Member
    Plugin Author

    Posted 8 months ago #

    Have you changed the menu titles in AME? Try resetting them to the defaults. If you set a custom menu title, usually it will overwrite the normal title. The bubbles are part of the title, so they would also get overwritten.

  3. Hassan
    Member
    Posted 8 months ago #

    I actually haven't changed the titles, but nonetheless, when I reset to default, the menu does show the bubble but it becomes kind of "sticky", meaning if the bubble says 2 it will just stay at 2 even if more posts had the pending status afterwards or if I publish all pending posts- the menu still says 2.

    If I go to AME again, the button to reset that menu's title to default appears again even though I just did that a while back and didn't touch it again. Only after I reset to default, the bubbles update again. Obviously, this makes them unusable since they should update live.

  4. Janis Elsts
    Member
    Plugin Author

    Posted 8 months ago #

    Looks like the problem is that Admin Tweaks adds a bunch of newlines to the menu title. AME isn't designed to support multiline titles so it will get confused and remove the "use the default title for this menu" flag if you click inside the menu title box.

    Try this: click the "reset to default" button, then click "Save Changes" right away. Do not click any other editor fields before saving this change.

  5. Hassan
    Member
    Posted 8 months ago #

    Yeah, that seems to fix it.

    Thanks for the help, Janis. I'll try to get AT's dev to improve this.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.