WordPress.org

Ready to get started?Download WordPress

Forums

WP-United : phpBB WordPress Integration
Issue with missing / (12 posts)

  1. leonjb
    Member
    Posted 1 year ago #

    I managed to get the plugin working but noticed at first the widgets had a missing / when trying to connect with anything..

    EG.. I click a widget or image from my sidebar and the url is shown as thegodlight.co.ukspiritualforum/image.png (missing / between thegodlight.co.uk and spiritualforum

    I started to get more worried when my avatars dropped of the wordpress install, and notice the same problem, when I clicked where the image should be..

    If I put the missing / in the url it works..

    Where can I put the missing / so that widgets and images work again.

    Most of the other things work.. You can upload images to the phpbb and users can upload images to wordpress, but the minute someone uploads to phpbb the wordpress image disappears due to the missing / in certain urls.

    http://wordpress.org/extend/plugins/wp-united/

  2. leonjb
    Member
    Posted 1 year ago #

    ok I sort of fixed it by checking any mentions of my main site in phpbb and wordpress and adding the / afterwards.. This connected things better.. But I have a problem where phpbb overides my wordpress avatars.. which on normal webpages is ok.. But my chat room now cannot read where the avatar file is situated so that goes blank.. You can also not change your avatar now on wordpress, phpbb is the only place you can change avatar.

  3. jhong
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    I think the slash problem is caused by your phpBB script path. It should be /forum, not forum. phpBB still works with an incorrect script path (unless you choose 'force values'), but WP-United needs them to be correct.

    For the second problem (avatars), WordPress never offers an option to update user avatars... you must be using a plugin for that? phpBB will only 'override' an avatar if the user has one set in phpBB. If not, then the WordPress one will show.

    After fixing your phpBB script path, you may need to re-sync users so that their correct avatar is shown. You can do this using the user mapper.

    Hope this helps,

    John

  4. leonjb
    Member
    Posted 1 year ago #

    I did force the url change to make it work.. I also changed it in setting on wordpress hoping something would resolve, which it did and it gave me two // put the plugin worked, not that I want to use plugins in the sidebar, I am happy with people finding the forum for themselves on nav links.. For users to be able to amend their wordpress avatar the only solution I had was to unsync accounts.. Where the problem is showing the most is in my chatroom, it uses the site avatars, but could not connect to a synced accounts avatar that had been amended.. So the solution so far which is really only a plaster over the problem, would be to unsync any phpbb accounts from wordpress if anyone gets the same problem with missing avatar.. As the problem is mainly in the chat room that i run, it should be easier to fix each persons problem as it arises.. Though I wish there was a way to sync accounts but to also have a choice of what avatar you want on either wordpress or phpbb..

    But please don't let all this come across as a slight on the plugin, without it I could not have achieved a single sign on for the whole of my site..

  5. jhong
    Member
    Plugin Author

    Posted 1 year ago #

    Hi, I'm not sure what you mean by force change the URL. You don't have to do anything like that -- just ensure the phpBB script path is correct. It must be correct in order for WP-United to work (not just for URLs). No need for double slashes or anything like that :-)

    Can you give an example of the broken URL in the chatroom? I expect it is caused by the improper settings as above... as WP-United should be providing a full (absolute) URL. Once the path is fixed clicking 'sync' in the user mapper should update the broken avatar to the correct one with the correct path.

  6. leonjb
    Member
    Posted 1 year ago #

    In wordpress settings I added an / to my site name thegodlight.co.uk
    on server settings in phpbb I did the same.. I put / after my domain name. I probably didn't mean force.. maybe I mixed that up with something else.

    This is my chat room Chat Room
    Now normally only guests get a blue bod.. But when I looked earlier the 3 account avatars I had changed in phpbb, lost their image in the chatroom.. The plugin for that is chatroll.. This also knocked off the avatar on site on posts and pages in wordpress.. Until I added the / then I unsynced the 3 accounts so they could regain their wordpress avatar and not the forum avatar..

    I have no link example as such of the broken avatar, but when I right clicked image to view it, it showed the avatar a blue bod was from chatroll, the same guests get.. By the way the accounts I was using are not chatroll accounts they are my site accounts.. The only chatroll account I have, I was not using. People who don't have avatars usually get a blue star on my site..

    So I don't know if its a chatroll problem, but when the accounts were synced, it could not connect with either the wordpress avatar or the phpbb avatar.

  7. jhong
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    That's not right... you should remove those two slashes, they won't resolve the issue.

    What do you have set for your script path in phpBB? it should be /spiritualforum , not spiritualforum.

    WP-United requires the script path to be set correctly in order to function properly.

  8. leonjb
    Member
    Posted 1 year ago #

    script path in phpbb is /spiritualforum I never put // anywhere. I put / after my domain name thegodlight.co.uk/ in phpbb server settings.. that must have resolved some of the problem.

    I put / after my domain name in wordpress settings.. hoping that might resolve the problem.. It did but not sure which change did it.. though the links still worked with // showing..

    Ive since saved and removed the / from wordperss settings.. which I just this second checked and it removed the // and back to / and working fine.

  9. leonjb
    Member
    Posted 1 year ago #

    But still blue bod in chat room after checking, though wordpress avatar. is still phpbb avatar. Thanks for taking time out to answer anyway jhong its good of you.

    Though I am still left with problem, all synced accounts take forum avatar no matter what which throws out chat avatar.. and will blank out main site avatar if someone uploads an avatar on phpbb. Luckily the forum is not accessible to members for a few days yet.

  10. jhong
    Member
    Plugin Author

    Posted 1 year ago #

    For the "blue bod", do you mean the WordPress default avatar?

    You could try visiting the user mapper, display all your users, and then choose "sync profiles" bulk action. That should sync the latest profiles and update the phpBB side with the correct avatar.

  11. leonjb
    Member
    Posted 1 year ago #

    I said before the blue bod was only given as default for chatroll guests, not for wordpress members.. I had already synced all accounts, the whole site is new and I am moving people from another forum.. The big issue is when they do get to use the new forum, they will attempt to change their forum profile pic at some time, this will cause problems on rest of site and mainly in my chatroom that uses wordpress avatars..

  12. jhong
    Member
    Plugin Author

    Posted 1 year ago #

    I see...

    Have you tried turning avatar sync off completely in the WP-United options? Then they would have separate forum avatars, but your chat would continue to work.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.