WordPress.org

Ready to get started?Download WordPress

Forums

Issue with Google Hilite (4 posts)

  1. Riduidel
    Member
    Posted 9 years ago #

    Hi, i've just installed WordPress from my provider's library. And I made a mistake : I've activated Google Hilite, which implies the display is now on each and every page the following : Fatal error: Cannot redeclare get_search_query_terms() (previously declared in /var/www/free.fr/b/5/nicolas.delsaux/wordpress/wp-content/plugins/google-hilite.php:12) in /var/www/free.fr/b/5/nicolas.delsaux/wordpress/wp-content/plugins/google-hilite.php on line 12
    Since I don't know the used version of WordPress (I guess it can be the latest stable), I'm sorry not to be able to give you more informations.
    By the way, I'm looking for a way to deactivate Google Hilite without access to the WordPress web interface. Any idea ?

  2. Beel
    Member
    Posted 9 years ago #

    Try renaming the plugin so it is not included.

  3. Riduidel
    Member
    Posted 9 years ago #

    Well, in fact, I've solved my issue :
    google-hilite was declared twice in the active_plugins option, stored in database. I've removed one of those declarations and it now work fine.
    Unfortunatly, it seems it's more or less a WordPress bug : once the user presses the activate button, WordPress does not checks if the plugin is already activated (which can happen since, to my mind, WordPress does not use any no-cache http header) and can indeed activate twice a plugin, which always result in double inclusion and that kind of bug.

  4. Beel
    Member
    Posted 9 years ago #

    Hmm, that has never happened to me and I switch on and off plugins often. If you think it is a bug you can certainly report it.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.