WordPress.org

Ready to get started?Download WordPress

Forums

Issue with config file (lines 19 & 20) (12 posts)

  1. dgreen36
    Member
    Posted 8 years ago #

    Warning: Unexpected character in input: '\' (ASCII=92) state=1 in c:\inetpub\wwwroot\blog\wp-config.php on line 19
    I filled in the wp-config.php install info and got the following errors when I executed /wp-admin/install.php:
    ========================================================
    Warning: Unexpected character in input: '\' (ASCII=92) state=1 in c:\inetpub\wwwroot\blog\wp-config.php on line 19

    Warning: Unexpected character in input: '\' (ASCII=92) state=1 in c:\inetpub\wwwroot\blog\wp-config.php on line 20

    Parse error: syntax error, unexpected T_STRING in c:\inetpub\wwwroot\blog
    ==========================================================
    I think I have set up the db correctly, what am I NOT doing correctly to the config file?

  2. Teli
    Member
    Posted 8 years ago #

    What is line 19 of the config file?

    According the the Warnings and Errors, there's something there that shouldn't be - but it's hard to tell if we don't know what your config file looks like :)

    (You can block or 'xxxx' your DB password...)

  3. dgreen36
    Member
    Posted 8 years ago #

    here is my config file:
    Maybe you can tell me whats going on.
    =========================================================
    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'wordpress'); // The name of the database
    define('DB_USER', 'root'); // Your MySQL username
    define('DB_PASSWORD', 'descentor'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value

    // Change the prefix if you want to have multiple blogs in a single database.
    $table_prefix = 'wp_'; // example: 'wp_' or 'b2' or 'mylogin_'

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');

    /* Stop editing */

    define('ABSPATH', dirname(__FILE__).'');
    require_once(ABSPATH.'wp-settings.php');
    ?>

    =========================================================

  4. Probably not a good idea to post your database username and password here.

  5. dgreen36
    Member
    Posted 8 years ago #

    so right you are. I have already changed it. However, I still need the question answered.

  6. moshu
    Member
    Posted 8 years ago #

    What did you use to edit the file? I mean what software, editor?

  7. dgreen36
    Member
    Posted 8 years ago #

    heh, MS-Word 2003. I dont see why that matters, but maybe you can elaborate.

  8. dgreen36
    Member
    Posted 8 years ago #

    If you want to email me at dgreen36@comcast.net and I will reply immediately

  9. moshu
    Member
    Posted 8 years ago #

    Hah! Too bad I don't bet on similar occasion (for say $1 million, LOL)
    Never again use that freaking Word :) Only plain text editors.

  10. Yep, there's the problem. Use Notepad or something. :)

    And moshu meant to post this link:

    http://codex.wordpress.org/Glossary#Text_editor

  11. dgreen36
    Member
    Posted 8 years ago #

    ok, great! I chaged the text editor I was using and sure enough, it loaded the \wp-admin\install.php file.
    Now, it seems to have a common problem that I read earlier. There is a lot of code on the page, and seemingly random text. I cant make heads or tails of it.
    It says:
    wp-config.php file. I need this before we can get started. Says this on the first line.
    It also say, "You appear to have already installed WordPress. To reinstall please clear your old database tables first."

    Thanks for the support guys. I'm glad I picked wordpress for this kind of support.

    David

  12. moshu
    Member
    Posted 8 years ago #

    If you see a lot of code that probably means PHP is not running on your server. Did you check for the requirements?
    See on the top if this page About > Requirements.

Topic Closed

This topic has been closed to new replies.

About this Topic