WordPress.org

Ready to get started?Download WordPress

Forums

Shareaholic | share buttons & related posts
[resolved] Issue with Bit.ly - defaulting to no URL shortner (11 posts)

  1. Niramaya
    Member
    Posted 1 year ago #

    Hello -

    I've entered the Username/API Key provided in my Bit.ly account but when testing the plugin (tweeting a post from my blog) it appears to default to full URL instead. Ex post: http://reasonandfolly.com/design/gallery-sample-3/

    Wondering if the "User ID" field Shareaholic has in settings for Bit.ly is different from the their Username.

    Pls advise.
    Thanks!

    http://wordpress.org/extend/plugins/sexybookmarks/

  2. Celeste - Shareaholic
    Member
    Posted 1 year ago #

    Hi! We are working out a few kinks in the URL shorteners currently. I did check your post and this is what populated in the Tweet dialog: Gallery sample - http://goo.gl/LJczC via @ReasonandFolly

    Have you switched to the goo.gl shortener, or does your tweet populate with a different short-link than mine (in your current settings)?

  3. Niramaya
    Member
    Posted 1 year ago #

    Hi again! Actually on my end, the tweet generated is: "Gallery sample - http://reasonandfolly.com/design/gallery-sample-3/ via @ReasonandFolly"--definitely have Bit.ly selected in settings along w/ UserUD/APIkey.

  4. Celeste - Shareaholic
    Member
    Posted 1 year ago #

    Hey again, could you check what happens when you remove your API key and username from the bit.ly shortener settings? After making this change, clear any caching plugins, CDNs, and your browser's cache, then go ahead and check the Twitter share dialog again. If you are having the same issue, I'll need your browser and operating system information so that I can test in a similar environment as this is what I'm getting on my end currently: http://cl.ly/image/3u05123Z0k3t

    Thanks for your help!

  5. Niramaya
    Member
    Posted 1 year ago #

    Good morning -

    I removed Bitly username/api but kept Bitly selected as shortner, then cleared browser cache. Result: "Gallery sample - http://bit.ly/175ZiVs via @ReasonandFolly"

    So in that instance it works but does not link to my Bitly account via username/api.

    I went back and entered username/api, cleared cache once more. Result: "Gallery sample - http://reasonandfolly.com/design/gallery-sample-3/ via @ReasonandFolly"

    I'm using Firefox 19.0.2, OS: MS Windows 7 Home.

    Mystery continues...

  6. Niramaya
    Member
    Posted 1 year ago #

    Hi there - wondering if my answer was at all helpful. Just checked once more and problem persists. What do you suggest I use for a setting until resolved?

  7. cpatience
    Member
    Posted 1 year ago #

    We're experiencing the same issue as well at http://www.makobiscribe.com.

    The bit.ly short link is correctly generated when there is no username/api information, but when that information is entered and saved, it does not show the shortlink anymore and uses the long link.

    Is there an update/resolution for this issue?

  8. Celeste - Shareaholic
    Member
    Posted 1 year ago #

    Hey everybody! We just rolled out an update a couple days ago that should have fixed the bitly API key issue. If you are still having problems, please submit a request at our support forum for individual assistance, and we'll be happy to help! http://support.shareaholic.com/home

  9. Niramaya
    Member
    Posted 1 year ago #

    Hey there - Wish I could say we're good to go but it now defaults to http://s.shr.lc/.....

  10. Shareaholic
    Member
    Plugin Author

    Posted 1 year ago #

    @all all template issues should be resolved. Please let us know if you're still seeing anything out of place.

    @Niramaya Currently, we're following end user shortening preference (which you can set on https://shareaholic.com/account/extensions) vs. the publishers. We're going to fix this to prioritize the Publisher defined setting. We anticipate rolling this out soon.

  11. Niramaya
    Member
    Posted 1 year ago #

    Thank you for the update. That did it! But certainly would make far more sense to prioritize publisher setting. Looking forward to fix. Cheers.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic