WordPress.org

Ready to get started?Download WordPress

Forums

CryptX
Issue with a custom field (4 posts)

  1. sofianemad
    Member
    Posted 10 months ago #

    Hello guys,

    I am using a theme called Jobroller and I would like to encrypt the email address that is in a custom field.

    This field may either contain text + href link to a page or text + href link to an email address.

    So I replaced this line:

    <?php echo apply_filters('jr_how_to_apply_content', get_post_meta($post->ID, '_how_to_apply', true)); ?>

    with

    <?php echo apply_filters('jr_how_to_apply_content', get_encryptx_meta($post->ID, '_how_to_apply', true)); ?>

    It works fine in the case of text + href link to an email address. But in the case of text + href link to a page, it messes up with the code (the link anchor is removed).

    Any idea why?

    Thanks

    http://wordpress.org/plugins/cryptx/

  2. sofianemad
    Member
    Posted 10 months ago #

    BTW I am using Cryptx 3.2.7 with WordPress 3.6

  3. sofianemad
    Member
    Posted 10 months ago #

    I found out that the issue only happens when there is an interrogation mark in the url. When the sign is removed from the URL it works just fine.

    Any idea how to fix this?

  4. Ralf Weber
    Member
    Plugin Author

    Posted 9 months ago #

    Hi Sofianemad,

    can you give me some sample data to feed my wordpress development sandbox?

    Kind regards
    Ralf

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.