WordPress.org

Ready to get started?Download WordPress

Forums

kPicasa Gallery
issue when clicking on an album thumbnail (12 posts)

  1. kioobee
    Member
    Posted 2 years ago #

    Hi

    First thanks for this wonderful plugin, this is really well done and simple to use !
    I have one issue though, when i click on an album from an album list, instead of displaying the particular album, it shows a page with all my post, but no album.

    The workaround i found is to create a dummy post, containing only
    KPICASA_GALLERY

    Then when i click on an album, this post will be shown among all other posts, and also show the desired album.

    I guess the best is to see it online :
    http://kioobee.com/lyon-international.org/

    click on any album, it will for example point to
    http://kioobee.com/lyon-international.org/?album=SortieEnPeniche

    because my last post is the dummy post, you'll see the album showing, but also all the other posts below ...

    If i dont create this dummy article, nothing shows up but the latest articles ...

    where could the problem come from ?

    Thanks for your time !

    Quentin

  2. kag
    Member
    Plugin Author

    Posted 2 years ago #

    I suggest you disable all other plugins and see if the problem remains. If the problem goes away, enable one plugin at a time until it becomes problematic.

  3. kioobee
    Member
    Posted 2 years ago #

    Thanks for your answer !
    Sorry to reply so late, but i wanted to keep you informed !
    I did what you recommended and found out that the NextGen-Gallery plugin was the one responsible for my problem.
    So it seems that your plugin and NextGen-Gallery are not compatible, i though you'd like to know. Maybe because it's competition ? :p

    Anyway, i had a little request :
    when clicking on the album thumbnail, is there a way to restore the browser vertical scrollbar position once the album is displayed ?
    Because right now i have to scroll back manually to the bottom of the page so i can actually see the pictures of the album ...

    Thanks again for this great plugin !

    Quentin

  4. kag
    Member
    Plugin Author

    Posted 2 years ago #

    I will look into NextGen-Gallery compatibility. As far as I know, kPicasa Gallery tries to play nice with other plugins. Maybe you could check with that plugin's author as well.

    Regarding the vertical scroll, could you post a link to your blog?

  5. kioobee
    Member
    Posted 2 years ago #

    Here it is !

    http://www.lyon-international.org

    The album listing is at the bottom

    cheers

    Quentin

  6. kag
    Member
    Plugin Author

    Posted 2 years ago #

    I had a look at it, it could be done with Javascript. But unfortunately it's not something that I'm willing to integrate directly into kPicasa Gallery.

  7. kioobee
    Member
    Posted 2 years ago #

    Ok, i'm sad to hear that :p

    Do you think there is a way for me to add this functionnality manually ?
    I don't speak javascript, only C++ :D

    Thanks again ! :)

    Quentin

  8. kag
    Member
    Plugin Author

    Posted 2 years ago #

    C++ is much more complex than Javascript :) If you know C++, you'll find your way around javascript without any problem :)

  9. JesseKHall
    Member
    Posted 2 years ago #

    I'm having a similar issue. Whenever I click upon the album in the list of all albums, it still shows the list of all the albums, rather than showing the images from the chosen album. The url updates, but it doesn't show the album's images.

    I disabled every plugin, however it does the same thing.

    Do you have any idea what may be wrong?

    http://www.jessekhall.com/photos/

  10. modsaid
    Member
    Posted 1 year ago #

    I'm having the same issue that is reported by @JesseKHall

    The listing of the albums is there, and when I click on any of the albums the url changes, but it is still the same listing.

    I never got to see the any of the album images themselves

  11. modsaid
    Member
    Posted 1 year ago #

    @JesseKHall I think i found the problem

    this plugin works well with the default premalinks.. it is not compatible with SEO friendly permalinks :S

  12. modsaid
    Member
    Posted 1 year ago #

    I updated my nginx configuration in order to have it working correctly with the query string part

    i used to have

    location / {
    try_files $uri $uri/ /index.php;
    }

    and had that changed to

    location / {
    try_files $uri $uri/ /index.php?$args;
    }

    http://wiki.nginx.org/Wordpress

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic