WordPress.org

Ready to get started?Download WordPress

Forums

Custom Sidebars
[resolved] Issue custom sidebars more the 30 widgets (11 posts)

  1. rick1975
    Member
    Posted 8 months ago #

    Hello,

    I discoverd that if you have more then 30 widgets its behaving weird.
    The first 10 widgets are normal but if you go further down the widgets. I can't do anything with the widgets, any ideas?

    Thanks!

    Rick

    http://wordpress.org/plugins/custom-sidebars/

  2. WPMU DEV
    Member
    Posted 8 months ago #

    Hi @rick1975,

    I hope you are well today and thank you for your question.

    I checked on my test site by adding more than 30 widgets but didn't find any weird behavior.

    Can you just test it by deactivating all plugins except Custom sidebars plugin and use default theme?

    Best Regards,

  3. rick1975
    Member
    Posted 8 months ago #

    Just deactivated all plugins changed theme but same behaviour of custom sidebars

  4. WPMU DEV
    Member
    Posted 8 months ago #

    Hi @rick1975,

    Thanks for your reply.

    Make sure you are using latest version of the plugin.

    Can you try enabling WP_DEBUG mode and debug logging? To do this, just go to wp-config.php include this:

    define('WP_DEBUG',true);
    define('WP_DEBUG_LOG',true);

    You might already have a line for WP_DEBUG, so just make sure it's set to true. This will create a log file under wp-content/debug.log with detailed information.

    If you'd like to avoid end users seeing error messages, you can include this as well:

    @ini_set('display_errors',0);
    define('WP_DEBUG_DISPLAY', false);

    This will prevent errors from being displayed, but you can still find them in the log file. For information on this, checkout this wpmu.org article.

    Also check the javascript console for errors? In Chrome go to "View -> Developer -> Javascript Console" and in Firefox you can go to "Tools -> Web Developer -> Consoleā€

    Let me know what errors if any you are getting!

    Best Regards,

  5. rick1975
    Member
    Posted 8 months ago #

    Hi,

    Below the errors

    Notice: Undefined index: WP_Widget_Recent_Comments in /home/italstudio/domains/staging.italstudio.nl/public_html/wp-content/themes/italstudio/lib/cleanup.php on line 22 Notice: Undefined offset: 0 in /home/italstudio/domains/staging.italstudio.nl/public_html/wp-content/themes/italstudio/lib/cleanup.php on line 164 Notice: Undefined offset: 0 in /home/italstudio/domains/staging.italstudio.nl/public_html/wp-content/themes/italstudio/lib/cleanup.php on line 164 Notice: Undefined offset: 0 in /home/italstudio/domains/staging.italstudio.nl/public_html/wp-content/themes/italstudio/lib/cleanup.php on line 165 Notice: Undefined index: jquery.mousewheel in /home/italstudio/domains/staging.italstudio.nl/public_html/wp-includes/class.wp-scripts.php on line 169 Notice: Trying to get property of non-object in /home/italstudio/domains/staging.italstudio.nl/public_html/wp-includes/class.wp-scripts.php on line 169

    Notice: Trying to get property of non-object in /home/italstudio/domains/staging.italstudio.nl/public_html/wp-content/plugins/dynamic-headers/custom-header.php on line 327 Notice: Trying to get property of non-object in /home/italstudio/domains/staging.italstudio.nl/public_html/wp-content/plugins/dynamic-headers/custom-header.php on line 327

    Notice: Uninitialized string offset: 0 in /home/italstudio/domains/staging.italstudio.nl/public_html/wp-content/themes/italstudio/templates/header-top-navbar.php on line 26

    Notice: Undefined index: jquery.mousewheel in /home/italstudio/domains/staging.italstudio.nl/public_html/wp-includes/class.wp-scripts.php on line 169 Notice: Trying to get property of non-object in /home/italstudio/domains/staging.italstudio.nl/public_html/wp-includes/class.wp-scripts.php on line 169

  6. WPMU DEV
    Member
    Posted 7 months ago #

    Hi @rick1975,

    Thanks for your reply.

    From the errors it seems that the theme italstudio and plugin dynamic-headers are causing to produce it so deactivating plugins and changing theme should make widgets functionality work but if it doesn't then try re installing latest version of WordPress so that any damaged WP core file will be recovered.

    Are you not getting any Javascript erros in Javascript Console when you are in widgets page in back end?

    Best Regards,

  7. rick1975
    Member
    Posted 7 months ago #

    Well, I have tried that but not succes.

    Why are the first 10 sidebars working as they should and after that they dont't?

    Even stranger I just noticed after 10 sidebars I can select a widget and when I drag it goes automaticly to the sidebar below. After 20 sidebars I cant select a widget at all.

  8. WPMU DEV
    Member
    Posted 7 months ago #

    Hi @rick1975,

    I have tested it on my test site creating 20 sidebars and also creating 30 widgets in a sidebar but i didn't face any issue in it.

    Can you just make sure you are using latest version of plugin?

    Can you test it by creating another test site and use latest WordPress version along with default theme and don't install any other plugin than Custom sidebars?

    Kind Regards,

  9. WPMUDEV
    WPMU DEV Support Staff
    Plugin Author

    Posted 6 months ago #

    Hey there.

    We haven't heard from you in awhile, so I just wanted to check in to make sure all was good.

    This thread was marked resolved, but please, if you still need help then just respond and open it back up. We can then take it from there. :)

    Hope you have a fantastic day!

  10. rick1975
    Member
    Posted 6 months ago #

    Hi,

    Thanks for the follow up.
    After updating the core to 3.8 the problem was resolved.

    Cheers,

    Rick

  11. WPMU DEV
    Member
    Posted 6 months ago #

    Hi Rick,

    Thank you for your reply and great to see you got that resolved.

    Any other issues, we're here to help.

    Cheers,

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.