WordPress.org

Ready to get started?Download WordPress

Forums

Is there the HTTP path in the database? (6 posts)

  1. Caps
    Blocked
    Posted 2 years ago #

    I had a dot net and dot com, I do not want to use the dot net anymore so I let it expire. It seems like in the db tables there is a reference to the dot net. Does anyone know where to find it so that I may edit it?

  2. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    Did you import posts from your .net domain's site?

  3. Caps
    Blocked
    Posted 2 years ago #

    Hi Krishna,

    The problem is the dot com is being re-directed to the dot net. I've already modified the paths in the config.php. So I am thinking there must a reference to the dot net in one of the DB tables.

  4. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    Please check it. That was precisely why I asked you.

  5. CallMeAndy
    Member
    Posted 2 years ago #

    Dont know if you are meaning when yo are following a link to a post it displays at the wrong url - if so there is a field in the wp_posts table named guid - this has hardcoded url - I havent checked to see if it is the cause of your problem however but I would guess that it might be the link foollowed to the post. If so and you have imported all posts from dot net they would need to be modified to meet the new url spec. Use the SQL replace command to change them all quite easily (phpMyAdmin has an easy to use interface)

  6. Caps
    Blocked
    Posted 2 years ago #

    Here are the steps:

    A - The domain expired

    B - Previously I could get both dot com and dot - I had the dot net resolving to the dot com - then changed it in the Apache setup to not resolve the dot net to the dot com

    C - Now if you type the dot com domain name you always get the dot net which goes to a Godaddy page - even after renaming the .htaccess

    D - If you add an "index.html" or rename the config, it no longer redirects to the dot net, you stay on the dot com

    E - To achieve having WordPress on the dot com I had to re-install WP using the "wp_" table index

    F - I kept the original db tables with wpX_ index. Now I have both, the default index "wp_" and "wpX_." I would like to go back and use the previous database with the "wpX_" index by setting the database tables in the config to the "wpX_" index.

    G - If I modify the config pointing it to the "wpX_" index, it redirects to the dot net

    H - From the above I deduced that it must be within the database redirecting to the dot net and not a script.

Topic Closed

This topic has been closed to new replies.

About this Topic