WordPress.org

Ready to get started?Download WordPress

Forums

Is there another way to upgrade databases if wp-upgrade doesn't operate? (5 posts)

  1. barcauan
    Member
    Posted 3 years ago #

    One of my sites (http://nosikov.ru/freeaudio/) was at 2.2.3 version.
    From one moment it started experiencing troubles (warnings, not being able to log in etc)

    I decided to upgrade to a version 3 as my other sites work well on it.
    I read and followed the procedure at Codex.
    But as I fail to log in as an administrator database is not upgraded (see errors at http://nosikov.ru/freeaudio/wp-admin/upgrade.php?step=1&backto=)

    The same happens when I try to update to a 2.9 version.

    I can login as administrator at a 3.0.1 version but can't update a database.
    What can I do finally upgrade it?

  2. Samuel B
    moderator
    Posted 3 years ago #

    wow - that is a large jump to upgrade
    you really should do it incrementally as the db has changed a lot
    upgrade
    2.2.3 -> 2.5 -> 2.7 -> 2.9 -> 3.0.1

    release archive
    http://wordpress.org/download/release-archive/

    also before upgrading, you might want to run a "repair" on the db tables with host's phpmyadmin

  3. barcauan
    Member
    Posted 3 years ago #

    Thanks, Samuel.

    The problem is not in upgrading process.
    The problem is that I am unable to upgrade because the standard procedure fails.
    As well as I fail to log in as administrator.

    So I seek other ways to I upgrade database.

  4. Here's a quote of the error for reference:

    PHP SCRIPT ERROR!

    Fatal error: Cannot use string offset as an array in /home/us5644/nosikov.ru/www/freeaudio/wp-includes/capabilities.php on line 116

    If you beleive that this error is due to the server configuration problems please contact your local web-hosting support team.

    Per a previous topic found by searching here for the error message, ask your hosting provider to turn off magic quotes.

  5. barcauan
    Member
    Posted 3 years ago #

    Per a previous topic found by searching here for the error message, ask your hosting provider to turn off magic quotes.

    Thank you for you comment, James.
    I turned off magic quotes via 1-string .htaccess file
    php_flag magic_quotes_gpc Off
    but I didn't help.

    I tested that magic quotes are really turned off in that directory.

Topic Closed

This topic has been closed to new replies.

About this Topic