WordPress.org

Ready to get started?Download WordPress

Forums

Is there an IE 10 Compatibility View workaround or fix? (5 posts)

  1. davidmerrifield
    Member
    Posted 10 months ago #

    I have a site at http://www.computerworld.co.uk that renders fine in every other browser I've tested, but is rubbish when viewed using IE10 when Compatibility View is switched on. My client themselevs run IE10 and it sees that Compatibility View is on by default. I can educate them to switch it off, but what about the big bad world? Is there any wisdom to do with a workaround or is there going to be no way to counter Microsoft's ridiculous apology for a browser? Any help greatly appreciated.

  2. MT
    Member
    Posted 9 months ago #

    David, I'm having the same problem. It seems that if I type in a full URL, like http://mtmcclanahan.com/ThePaintersTongue, in IE10, the site has problems--and stays in Compatibility View. If I put in only http://ThePaintersTongue.com, all is fine. As you say, Compatibility View is, by default, on in IE10 (and I don't know how to change it) but with the shortened URL it is not on.

    I looked at your site on IE10 and on Google and they looked the same and seemed ok (I'm not a computer person though), and CV was on by default at the time. So I wonder how mine looks from your end?

    Previewing a post from the edit page of WordPress shows the full url also and is also in CV mode, making things look wrong while previewing.

  3. davidmerrifield
    Member
    Posted 9 months ago #

    Hi
    Thanks for your note. My site was cured with a bit of code, I think. I was not responsible for it (I am also not as technical as I ought to be), but I shared the issue with a WP-savvy colleague, and he sorted it. I will contact hime and see if I can add another post here for you and the world at large top benefit from...
    David

  4. davidmerrifield
    Member
    Posted 9 months ago #

    Right. Here's the solution:

    The following tag was added:

    <meta http-equiv="X-UA-Compatible" content="IE=10,IE=9,IE=8" />

    It has to be the very first meta tag in the head (but can be after the title tag). This essentially tells each browser to render with that version's layout engine, not the IE7 (quirks mode) engine.

    Hope this helps. It seems to do the trick.

    David

  5. MT
    Member
    Posted 9 months ago #

    Thanks David. I found (by accident) that my theme had an option to force compatibility view, which I had clicked long ago. But I will hold on to that tag! Thanks again.

Reply

You must log in to post.

About this Topic