WordPress.org

Ready to get started?Download WordPress

Forums

  1. fosji
    Member
    Posted 1 year ago #

    hello,
    is installed, I also have the icon on the menu bar, I have the setting page but it doesn't show up. I saw the video tutorial and followed all the steps.
    the mp3 link is as usual, no player.
    I noticed that in the video, when you open the setting window from the menu bar icon, it is activated and it reads the link data. In my case the fields are empty and the code field is plain text.
    If I fill all the fields, and click the code field I get again the same window with empty fields.

    http://wordpress.org/extend/plugins/wp-miniaudioplayer/

  2. pupunzi
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,
    When you insert the audio file in the page take care that in the dialog window the "Link URL" contains the path to the audio, otherwise the editor will insert just the name of the file and the player won't work. If the field is empty you should click on the "file URL" button just below it.

    Bye,
    Matteo

  3. fosji
    Member
    Posted 1 year ago #

    Hi Matteo,
    thank you for answering. I tried everything and listen carefully to the tutorial, and what I understand is that when I insert"normally" the mp3 in the post, from the media library, the plug in is supposed to read it automatically. My question is which dialog box do you mean, since I deal only with the WordPress media library, after the installation and setting the plug in. I think missing something.
    In the video you make the example inserting the mp3 in a page, I need it in the posts, does it make a difference?

  4. fosji
    Member
    Posted 1 year ago #

    Hi again Matteo,
    I found out that the problem is a bug in this blog because I tried it in another one and it works just fine.
    I'll ask for help to another thread because in the same blog also the follow button from Jetpack doesn't show up, and also this one works fine in the other blogs.

    Thank you

  5. pupunzi
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,
    I think that your problem is that when you insert the audio file using the upload/insert button you should control that the "file URL" field contains the path url to the audio. If that field is empty than the TinyMCE will insert in the page just the name of the file and not the link; this would prevent the correct behavior of the plugin.
    You can verify that by checking if the inserted element is a link or not just looking at the color of the text: if it's blue than a link is inserted; if it's black than just the title is inserted and if you go to the page preview you'll see just the name of the audio and not the player.

    Hope this can help you,
    Bye,
    Matteo

  6. fosji
    Member
    Posted 1 year ago #

    I found out that both this plug in and the follow button are incompatible with other plug in.
    Thank you Matteo. The plug in is very good.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic