WordPress.org

Ready to get started?Download WordPress

Forums

I can not upload pics to my blog (14 posts)

  1. vlarry
    Member
    Posted 6 years ago #

    I have this error message when I'm trying to upload pics. files to my blog, please someone help me???

    Unable to create
    directory /hsphere/local/home/example/example.com/wordpress/wp-content/uploads/2007/10. Is its parent directory writable by the server?

  2. ungerente
    Member
    Posted 6 years ago #

    ok, in my blog happens the same

  3. ungerente
    Member
    Posted 6 years ago #

    and the comments don´t sends to the mail account

  4. moshu
    Member
    Posted 6 years ago #

    The error message says exactly what you need to do:
    Is its parent directory writable by the server?
    No, it isn't, that's why you get the error.
    The "parent" is wp-content. Needs chmod 777.

  5. ungerente
    Member
    Posted 6 years ago #

    The uploaded file could not be moved to /home/gerente/public_html/wp-content/uploads/2007/10.
    WordPress
    93

    this is a transcription to message, and the comennts don't send to mail account.
    thanks a lot for you help

  6. moshu
    Member
    Posted 6 years ago #

    Make a habit of entering your error message in the search box...
    http://wordpress.org/search/The+uploaded+file+could+not+be+moved+to?forums=1

  7. ungerente
    Member
    Posted 6 years ago #

    moshu,
    thanks a lot for you help, problem solved, i change permision to wp-content folder and subfolders to 777 via ftp (in my case filezilla)
    second problem is: comments not send to my mail account, what is the problem?
    again thanks for your help, i'm a rookie in wordpress

  8. moshu
    Member
    Posted 6 years ago #

    WP is using the mail() function of your server - if enabled. Ask the host. If disabled, search for some SMTP solution/plugin here in the forum or in the Extend section (see up).

  9. vlarry
    Member
    Posted 6 years ago #

    Can you explain for dummy little more, I'm new at this stuff, (i change permision to wp-content folder and subfolders to 777 via ftp)
    How to do it????????
    Please,Please................

  10. ungerente
    Member
    Posted 6 years ago #

    ok, in FTP manager (filezilla, for me) you pick right click)in "wp-content" folder and select atributes, then yow mark all options, a number in that window changes for 777, pick an select included subfolders an click go.
    this proces take a few minutes, closse the ftp manager and try to upload the pictures, tell us if solved your problem
    sorry about my bad english

  11. vlarry
    Member
    Posted 6 years ago #

    do I have to download filezilla?

  12. ungerente
    Member
    Posted 6 years ago #

    yes you have to dowunload filezilla client, I try on cpanel files manager but doesn´t work

  13. ungerente
    Member
    Posted 6 years ago #

    moshu: ok, in my host function mail() isn't enable for security reasons :(
    please, if you can, recomended me a wp plugin for wordpress 2.3

    thanks

  14. buckymcsatan
    Member
    Posted 6 years ago #

    Is my parent directory writable by the server?
    Yes it is. (And so is 'uploads'.) Then why am I still getting the error:

    Unable to create directory /var/www/vhosts/sitename.com/httpdocs/WordPress/wp-content/uploads/2008. Is /var/www/vhosts/sitename.com/httpdocs/WordPress/wp-content/uploads writable?
    Back to Image Uploading

    WordPress 2.0 - 0.28

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags