WordPress.org

Ready to get started?Download WordPress

Forums

AutoNav Graphical Navigation and Gallery Plugin
Is it possible to updateFAQ? (7 posts)

  1. nicole2009
    Member
    Posted 1 year ago #

    I was wondering if it is by any chance possible to update the FAQ with a list of errors that the plugin gives and a short explanation on what causes that error. It will help people fix errors without bothering you.
    For example, I get the following errors on a one page:

    Warning: imagecreatefromgif() [function.imagecreatefromgif]: '/home/persoob6/public_html/wp-content/uploads/2012/03/smurf.gif' is not a valid GIF file in /home/persoob6/public_html/wp-content/plugins/autonav/autonav-wl.php on line 109

    Warning: imagesx(): supplied argument is not a valid Image resource in /home/persoob6/public_html/wp-content/plugins/autonav/autonav-wl.php on line 50

    Warning: imagesy(): supplied argument is not a valid Image resource in /home/persoob6/public_html/wp-content/plugins/autonav/autonav-wl.php on line 50

    Warning: imagesx(): supplied argument is not a valid Image resource in /home/persoob6/public_html/wp-content/plugins/autonav/autonav-wl.php on line 133

    Warning: imagesy(): supplied argument is not a valid Image resource in /home/persoob6/public_html/wp-content/plugins/autonav/autonav-wl.php on line 133

    Warning: imagejpeg(): supplied argument is not a valid Image resource in /home/persoob6/public_html/wp-content/plugins/autonav/autonav-wl.php on line 141

    Warning: imagedestroy(): supplied argument is not a valid Image resource in /home/persoob6/public_html/wp-content/plugins/autonav/autonav-wl.php on line 148

    Warning: imagecreatefromjpeg() [function.imagecreatefromjpeg]: gd-jpeg: JPEG library reports unrecoverable error: in /home/persoob6/public_html/wp-content/plugins/autonav/autonav-wl.php on line 103

    Warning: imagecreatefromjpeg() [function.imagecreatefromjpeg]: '/home/persoob6/public_html/wp-content/uploads/2010/04/cat.jpg' is not a valid JPEG file in /home/persoob6/public_html/wp-content/plugins/autonav/autonav-wl.php on line 103

    Warning: imagesx(): supplied argument is not a valid Image resource in /home/persoob6/public_html/wp-content/plugins/autonav/autonav-wl.php on line 50

    Warning: imagesy(): supplied argument is not a valid Image resource in /home/persoob6/public_html/wp-content/plugins/autonav/autonav-wl.php on line 50

    Warning: imagesx(): supplied argument is not a valid Image resource in /home/persoob6/public_html/wp-content/plugins/autonav/autonav-wl.php on line 133

    Warning: imagesy(): supplied argument is not a valid Image resource in /home/persoob6/public_html/wp-content/plugins/autonav/autonav-wl.php on line 133

    Warning: imagejpeg(): supplied argument is not a valid Image resource in /home/persoob6/public_html/wp-content/plugins/autonav/autonav-wl.php on line 141

    Warning: imagedestroy(): supplied argument is not a valid Image resource in /home/persoob6/public_html/wp-content/plugins/autonav/autonav-wl.php on line 148

    Thanks!

    http://wordpress.org/extend/plugins/autonav/

  2. wlindley
    Member
    Plugin Author

    Posted 1 year ago #

    Hmm... do those files actually exist on your system? Is there a URL for a copy of the "GIF file that is not a GIF file" ? None of those things should happen unless you have a corrupted file...

  3. nicole2009
    Member
    Posted 1 year ago #

    I finally worked out the problem but I don't know how to solve it. It seems like my images are uploaded with a .gif but the plugin looks for .GIF

    For example http://www.yetzira.com/wp-content/uploads/2013/05/abcmaze.gif is a valid file but http://www.yetzira.com/wp-content/uploads/2013/05/abcmaze.GIF returns an error.

    Anyway to fix this?

  4. nicole2009
    Member
    Posted 1 year ago #

    Is there a way to get the plugin to accept both GIF or gif, png or PNG and jpg or JPG?

  5. wlindley
    Member
    Plugin Author

    Posted 1 year ago #

    Very strange. With version 1.5.4 of AutoNav, I uploaded two files in an example domain -- test.gif and TEST1.GIF -- and both worked properly.

    WordPress modified the second one, during upload, to actually be TEST1.gif (lowercase extension) so then I also manually FTP uploaded TEST2.GIF (uppercase extension) and use the form [autonav display=/2013/05] to display all the images uploaded this month; all three images displayed properly.

    I have double-checked the code, and it appears to handle both upper- and lower-case extensions properly. Perhaps I will have to look inside your installation. Please contact me via email again.

  6. nicole2009
    Member
    Posted 1 year ago #

    Thanks so much for checking this out.

    I sent you an email with user details. I hope that the email is correct.

    This is an example of one of the pages with the errors (there are quite a few pages with these errors):
    http://www.yetzira.com/%D7%94%D7%9B%D7%A0%D7%94-%D7%9C%D7%9B%D7%99%D7%AA%D7%94-%D7%90.html

    Thanks again!

  7. nicole2009
    Member
    Posted 1 year ago #

    Something very strange happened. I just moved my site to a new host (haven't yet changed DNS). I now have 2 identical sites on 2 hosts. The original site shows all of these errors on a lot of the pages but the new site (which is identical just on a different host/server) doesn't have any errors.
    Could there be something that needs to be configured on the server to prevent these errors?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.