WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Is it possible to remove the 'index.php' from permalinks? (9 posts)

  1. Tunghsiao Liu
    Member
    Posted 8 years ago #

    I have a Apache server, however, I have to show the 'index.php' when I use permalinks:( I think it's uly.

    Is there any way to remove the 'index.php' from permalinks?

    Thanks!

  2. VaamYob
    Member
    Posted 8 years ago #

    If you MUST include index.php in order to get permalinks working then you don't have permalinks working correctly.

    The answer then is, "yes" you can have permalinks without index.php

  3. Tunghsiao Liu
    Member
    Posted 8 years ago #

    thanks for replying.

    but i just read the notice in my admin:

    For the above to work you must have something called mod_rewrite installed on your server. (Ask your host.) If that isn’t available, you can prefix the structure with /index.php/ . This is the recommend method if you are on any web server but Apache.

    How?

  4. VaamYob
    Member
    Posted 8 years ago #

    Are you asking how to get mod_rewrite installed ?

  5. Tunghsiao Liu
    Member
    Posted 8 years ago #

    No, i've installed correctly, and i can only view my post in such form: http://example/index.php/archives/abc/

    I want to use http://example/archives/abc/ but it is unavailable.

  6. VaamYob
    Member
    Posted 8 years ago #

    What do you mean by, "unavailable" ?

    If you've configured mod_rewrite correctly and have .htaccess set to the right permissions, then you don't need index.php in order for your permalinks to work.

    If index.php must be in there in order for your urls to resolve correctly then you don't have permalinks configured completeley.

  7. altacivil
    Member
    Posted 8 years ago #

    I had that same problem of haveing index.php in front of all my permalinks... I found that when I created an .htaccess file (a brand new one... dont delete your other one) and placed it in the root directory for my wordpress install and enabled permalinks, it worked...
    so... for me my wordpress install is in http://gpetzold.swifthost.net/wp so when I created my .htaccess file, I placed it in "public_html/wp" (not in the directory where your theme is).

    Hope that helps

  8. handry
    Member
    Posted 8 years ago #

    I am using .html extension as my post permalinks.
    For the new version of WordPress 1.5.2 there is no .htaccess rewrite rule generator.

    During some trying and error then I found out some solution. Try this URL:
    http://www.handry.com/do-you-have-problem-with-wordpress-permalink.html

  9. Tunghsiao Liu
    Member
    Posted 8 years ago #

    Ok! I know my apache is not configured completeley.

    i changed Options FollowSymLinks in my Apache httpd.config is just ok.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.