WordPress.org

Ready to get started?Download WordPress

Forums

Is it possible to downgrade from 2.2? (12 posts)

  1. pinkdivinity
    Member
    Posted 7 years ago #

    Upgraded to 2.2 and I *HATE* it.

    This widget-ready version doesn't allow me to assign specific widgets to appear on specific pages. Everything appears EVERY PAGE whether I want it to or not.

    In my previous version, 2.1.1, I used a plugin called Sidebar Modules by Nybble Labs, which worked with any widget-ready theme. It had the capacity to do exactly what I described above.

    I naively thought that since WP 2.2 was "widget ready" I could simply use this plugin and things would run as I normally had them.

    After the upgrade, I discovered that Sidebar Modules is incompatible.

    I then found a plugin that supposedly disables the "widget-readiness" of WP 2.2.
    I installed that one, tried using Sidebar Modules and it LOOKED like everything was working smoothly to me.

    Unfortunately, to my readers, the page took an eternity to load or even caused their browser to hang, requiring them to close via ctrl-alt-delete!!

    SO... for the past week or so my page has been all messed up and I've lost readership... and possibly income because I sell my artwork and handmade jewelry through my site as well.

    Does anyone know a good way to downgrade back to my previous version or have another solution?

    *Any* help would be greatly appreciated.

  2. MichaelH
    Member
    Posted 7 years ago #

    If you followed the Upgrading WordPress instructions you have backups. If you have backups, I suppose you could delete the 2.2 wordpress files, drop database tables and restore, files and database from your backups.

    If you decide to go that way, please backup your 2.2 files and database first.

  3. etoile
    Member
    Posted 7 years ago #

    What is the plugin that disables widget-readiness? I'm having issues with 2.2 as well and I'd like to try that as part of my troubleshooting process.

  4. Dgold
    Member
    Posted 7 years ago #

    I posted a thread asking similar question here:
    http://wordpress.org/support/topic/120010?replies=1

    I am also starting to Not Want WP 2.2, for different reasons that I won't detail here, but check my other threads if interested (My feeds broke, and my Admin screens go to Blank pages after pushing Publish or Edit).

    @MichaelH, thanks for the help ---- I have my old backups. I have a question about the steps you listed. So, you are saying it is possible to Keep my 2.2 Database (merely dropping tables - which tables?), as opposed to Deleting my Database and restoring from the backup database I had under WP 2.0.x?

    Which way should I go --- (1) Delete Everything (DB and WP files), and restore everything from my 2.0.x backup.

    or, (2) Delete my WP files, Keep my 2.2 DB, drop tables, and restore only the files from 2.0.x?

    ALSO: 2.2 messed up my character encoding in some places but not in others. I looked in the database and the bad characters are there (a black diamond question mark, instead of an apostrophe, for example). If I go back to 2.0.x, will it fix my character encoding? Or is this another reason to delete my database entirely and restore from a 2-week old backup?

  5. MichaelH
    Member
    Posted 7 years ago #

    If you did a backup of your database, you should DROP all the tables that are in your backup, then restore from your backup. If you upgraded, the upgrade did NOT create a new database (that would have been created as part of the initial installation). Now I can't tell you exactly what tables you should drop, because some plugins create their own tables. I can point you to the list of 'standard' tables, as detailed in the Database Description article. There were no new database tables added from 2.1.x to 2.2, but there were new tables added (and deleted) from 2.0 to 2.1.

    If you backed up your wordpress files, then delete all the wordpress files, including wp-config.php, then restore from those backup files (typically this would be an upload via FTP to your host).

  6. drmike
    Member
    Posted 7 years ago #

    I believe you can also just remove the bit out of your theme's function.php file that activate the widgets as well. Don't see why that wouldn't work.

  7. Dgold
    Member
    Posted 7 years ago #

    Thanks MichaelH.

    "If you did a backup of your database, you should DROP all the tables that are in your backup, then restore from your backup."

    Did you mean to write, "you should DROP all the tables that are in your database, then restore from your backup"? I don't think you meant for me to drop tables from my backup.

    Any good reason to DROP ALL TABLES (I think this empties the DB), instead of starting with a fresh empty DB and pulling-in my backup DB?

    To be honest, I'm thinking --- to be safe --- that I should just delete that 2.2 database completely. I can make a new database on my host, different DB name. Then I would import my old 2.0 DB backup into the new database. Then I wouldreinstall WP 2.0.x, and I would change the wp-config to point to the new database.

    Then I would re-type or copy-paste my missing recent posts.

    Sound good?

    For the record, I upgraded from WP 2.0.x to 2.2. I never had 2.1 because I was busy with school when it came out.

    I know how to upload my files by FTP. I also sort-of know how to Import my backup DB, following the guides on Podz' site.

  8. MichaelH
    Member
    Posted 7 years ago #

    "If you did a backup of your database, you should DROP all the tables that are in your backup, then restore from your backup."

    Simply, drop the tables (but don't drop them until you are sure you have them in your backup).

  9. Dgold
    Member
    Posted 7 years ago #

    Yes, I am a confused individual, trying to get it.

    Do you mean, don't drop tables which aren't in my backup? Only drop the tables which are replicated in my backup?

    Then it seems like I would be importing my old 2.0 tables, into a database that is mostly empty except it would have some extra tables added by 2.1 / 2.2? I wouldn't think I would want that.

    Or do you mean, drop all tables & empty the database, period?

  10. MichaelH
    Member
    Posted 7 years ago #

    Not all databases tables are solely WordPress related. Some users only have one database, and that database must house all the tables for all their software packages, including those for WordPress.

    In your case if you just have WordPress tables in your database, then drop all tables in that database.

    Sorry for the cloudiness.

  11. Dgold
    Member
    Posted 7 years ago #

    Thanks again MichaelH.

    I can have 7 databases on my host, so I pretty much have just 1 WP install per database, in my set-up.

  12. Dgold
    Member
    Posted 7 years ago #

    I'm not downgrading after all. My blog is fixed, the problem was a "space" at the end of a Plugin php file.

Topic Closed

This topic has been closed to new replies.

About this Topic