WordPress.org

Ready to get started?Download WordPress

Forums

Irritated by the installation problem. 5 mins my a (15 posts)

  1. Anonymous
    Unregistered
    Posted 10 years ago #

    This is what i get. can anyone help me how to get pass this problem???
    "We're having a little trouble selecting the proper database for WordPress.
    Are you sure it exists?
    Your database name is currently specified as betanerd_wordpress. Is this correct?
    On some systems the name of your database is prefixed with your username, so it would be like username_wordpress. Could that be the problem?
    WordPress Support Forums"

  2. Lilandra
    Member
    Posted 10 years ago #

    well what's the name of your database in your mysql admin?

  3. Anonymous
    Unregistered
    Posted 10 years ago #

    betanerd_wordpress
    thanks for the help lilandra

  4. Lilandra
    Member
    Posted 10 years ago #

    okay! i can't figure it out :-(

  5. charle97
    Member
    Posted 10 years ago #

    did you create the database? what type of database are you using? what's the url to your hosting provider, so that we can see what conventions they use?

  6. crow_t_autobot
    Member
    Posted 10 years ago #

    I'm getting the exact same error for my server.
    I can get into my MySQL server, but there are no tables created under it, should I create one? If so, what should the table name and attributes be?
    I'm hosted by Barron Hosting at http://www.barronhosting.com
    My site is http://www.cybertroncinema.net
    Thanks for any assistance.

  7. TechGnome
    Moderator
    Posted 10 years ago #

    1) Is the password right?
    2) Is the database server right (some hosts don't allow you to use localhost)
    TG

  8. destry
    Member
    Posted 10 years ago #

    This might just be a shot in the dark, but it turned out to be the problem for me back when I had that same error.
    As it happened, I had everything correct on the WP end of things (i.e., changed the config file properly, etc.), and had even set up the database accordingly, but what I overlooked was in addition to creating a user account for myself with the database, I ALSO had to "assign" myself as a user to the database, i.e., assign the account I created for myself to the database. In my hosts site management interface (Cpanel), this was a two-step process.
    It took me a frickin week to figure it out, and only then thanks to someone in the forum over at my web host, but once I assigned myself, the setup worked like a creamcicle.
    That's my two cents.
    -d

  9. eric
    Member
    Posted 10 years ago #

    I just had the same problem with WP1.2 beta on a server using Cpanel, which I'm not really familiar with. After much head-scratching I found out that creating a database and a user is not enough, I also had to "add user to DB". I don't mean to suggest that you're as daft as me, but I'm posting this just in case.

  10. destry
    Member
    Posted 10 years ago #

    Yes, that's pretty much what I just described, though Eric used the proper quote probaby..."add user to DB", which is what I meant by assigning myself to the database.
    -d

  11. Anonymous
    Unregistered
    Posted 10 years ago #

    Maybe there should be options for creating a new database and a user to run WP within the installation. This is a very straightforward thing to do in terms of PHP.

  12. carthik
    Member
    Posted 10 years ago #

    @Anon, that would be a major problem, since, then anyone can set up any number of databases on your server, just by going to install.php! That's why the database has to be set up by the user seperately.

  13. Lilandra
    Member
    Posted 10 years ago #

    i did that...added user to database but for some reason i still couldn't install it...oh well...

  14. carthik
    Member
    Posted 10 years ago #

    Cpanel database creation guide ...
    http://wiki.wordpress.org/index.php/Cpanel
    If you find mistakes in the guide, you can fix them too! :)

  15. Lilandra
    Member
    Posted 10 years ago #

    i think part of my problem was the user name created was too long...and it went all screwy on me...and then i just gave up and left it for another day..

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.