WordPress.org

Ready to get started?Download WordPress

Forums

Media Tags
[resolved] Irregular slug creation when adding tags in bulk edit in Media library (2 posts)

  1. definitio
    Member
    Posted 1 year ago #

    First of all, thank you for this great plugin.

    Since moving to WordPress from Joomla, where I used to upload media to folders of my choosing, I have felt the dire need to organize the media items to be able to locate them faster and efficiently.

    You plugin does it all:
    - Adding tags on upload
    - Adding tags in bulk edit
    - Using a separate taxonomy than WP tags (this is a good option to have, cause I don't want to have my media items linked through WP tags in frontend, BUT IT MIGHT BE USEFUL TO BE ABLE TO IMPORT WP-TAGS AS MEDIA-TAGS)

    The problem:
    I use non-latin alphabet language in the site and to avoid issues of character encoding I am using a plugin that transliterates non-latin characters into latin slugs
    --> When adding tags in bulk edit and on Media popup within the post, the regular slug creation process is somehow circumvented and the slugs created are actually in non-latin chars.

    When adding tags to media items in other ways, the slugs to get transliterated.

    - Is there a way to make sure that slugs for Tag names will be created the same way as in adding them through the media-tags separate menu?
    - Can one use the WP tags to tag media items?
    (for both) if not any chance of seeing this in the future?

    Cheers

    http://wordpress.org/extend/plugins/media-tags/

  2. Paul Menard
    Member
    Plugin Author

    Posted 1 year ago #

    @definitio,

    Just updated Media-Tags 3.1.2 which should solve your issue. See this other thread. http://wordpress.org/support/topic/media-tags-slug-sanitizing-not-working-on-special-characters?replies=5

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic