WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
[resolved] IPN SORTOF not working (9 posts)

  1. kipprsnak1
    Member
    Posted 1 year ago #

    I get IPN statements in order comments but the order never moves over to pending. The order note says "IPN payment completed." When I force the order to completed, it doesn't impact the inventory.

    I've run all the system checks and they are ok. I've tried all kinds of things that are questionable but have been said to work. And then reverted again.

    I am sort of at my wits end. Looking for any insight, guidance, wisdom, whatever is out there.

    Thanks!

    http://wordpress.org/extend/plugins/woocommerce/

  2. mikejolley
    Member
    Plugin Author

    Posted 1 year ago #

    What status does the order have?

  3. kipprsnak1
    Member
    Posted 1 year ago #

    OMG. I am so sorry. Okay -it won't leave pending. I've seen that a lot of people have this problem. Let me just run down what I've already done:

    1. Turned off all of my plugins and was running only woo commerce. Didn't change anything -and I've never been running a caching plugin (though maybe I should).

    2. Ran the systems setting test in the administrative area - all green. No problems.

    3. Added the new paypal gateway from git hub

    4. Downloaded and reinstalled the whole woocommerce plugin. No dice.

    5. Double checked with my host if there were any problems with receiving IPN's from paypal, and no.

    All along, the logging showed successfully completed payments. They show up in the notes section of each order. Forcing complete does not increment (or decrement) the inventory.

    I hope this helps. I'm wondering if I've missed some crucial setting...
    Thanks for your help.

  4. mikejolley
    Member
    Plugin Author

    Posted 1 year ago #

    Sorry, I don't understand :) When you look at a new order, which in the order notes says payment complete, is the order status:

    a) pending
    b) on-hold
    or c) processing

    :)

  5. kipprsnak1
    Member
    Posted 1 year ago #

    OH, and when I process a refund from PayPal, it works. I get the email, the icon changes to the refund icon in the orders dashboard. It's just the darn "complete."

  6. mikejolley
    Member
    Plugin Author

    Posted 1 year ago #

    I've responded on support asking for a login. lets work it out there, then you can come back here later and let everyone know how we did ;)

  7. kipprsnak1
    Member
    Posted 1 year ago #

    just to update anyone else who runs into this problem. First, Mike rules. Thanks so much for your help! Second, I had a pre-existing "pending" in the taxonomy table, so then WC couldn't use it and reset my orders appropriately. If all your other IPN stuff is working, go to the system status and check at the bottom to make sure your statuses all look right.

    Thanks again to Mike, this was a very specific situation and I am so grateful Mike and Woo took the time to get me on track!

  8. kipprsnak1
    Member
    Posted 1 year ago #

    This issue is resolved for me!

  9. jack@malago.co.uk
    Member
    Posted 7 months ago #

    What do you mean 'Look right'?

    I have:
    WC Taxonomies
    Order Statuses: cancelled (cancelled), completed (completed), failed (failed), on-hold (on-hold), pending (pending), processing (processing), refunded (refunded)

    It looks right to me, but I have the same problem..

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.