WordPress.org

Ready to get started?Download WordPress

Forums

ecSTATic
[resolved] IP: 127.0.0.1 Domain: localhost - Keeps getting logged (3 posts)

  1. mixtlupus
    Member
    Posted 1 year ago #

    I keep seeing repeated entries for localhost visits (when the website requests a page from itself), I have had the plugin installed less than an hour and can already see over 40 which is making the logs hard to read...

    Is there somewhere I can add an IP ignore list so these don't get logged?

    http://wordpress.org/extend/plugins/ecstatic/

  2. MikeSoja
    Member
    Plugin Author

    Posted 1 year ago #

    You can set the NoLog flag in the Details page.

    Click the score in any of the listings to go to the Details page. The select the IP, or enter it in the small form at the top right of your screen. Choose "NoLog", add a name in "Common Name", then click "Submit Token".

    Also, there used to be an explicit block in the program, but I never saw it being used, so I commented it out. It's in ecstatic.php at line 383. You could uncomment the two lines there (leave the others alone as I see hackers targeting the "themes" URIs) and I'll put them back in next release, too.

  3. MikeSoja
    Member
    Plugin Author

    Posted 1 year ago #

    Oops. My memory is faulty. I changed the function call, so uncommenting those lines won't do anything. The fix is still simple, but will require a couple of extra lines. Use the NoLog flag in the meantime.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic